02-23-2016 05:14 AM
285 123 ...
  1. Joel Innard's Avatar
    Hi everyone this is my first post so be gentle. I recently bought an S4 and all was well until I decided to start using the phone to listen to music. Whenever I listen to music on the phone after a minute or two I get a message saying "SD Card removed unexpectedly". This message continues to display until I restart the phone or physically remove the SD Card and re insert. The SD Card is 64GB so it shouldn't be a compatibility issue. I've had a look on the internet already to see if anyone else has been having this problem but no such luck. If anyone could shed some light on the issue I would be grateful.

    Thanks for reading!
    Alex Ranah Minang likes this.
    05-07-2013 09:12 AM
  2. glrserdar's Avatar
    Hi, i have same issue as well. I bought 64 gb micro sd sandisk memory card and since I start use I have.
    Today I put sticky type on the card and I format the card from phone settings.

    Now I'm watching whats going to happen.

    Once when I had the problem I open back lid and sd card wasn't in the socket.
    05-08-2013 01:15 AM
  3. GMJeff's Avatar
    Not to be doubting your skills with cell phones, but did you push the card all the way in until it clicked.

    You push the card in until it feels like it is all the way in. Then you push it in a little more until you hear a click, then release the card, you should hear a second click, and it should be set.

    A small mechanical arm/tab interacts with the sd card and holds it in place. This is so that vibration or expansion/contraction from heat does not loosen the card and let it disconnect.

    Once again, please do not think I am questioning your intelligence, but people miss these little things sometimes and think their devices are faulty or broken.

    Sent from my SAMSUNG-SGH-I337 using Tapatalk 2
    05-08-2013 01:36 AM
  4. asdfasdf's Avatar
    I know my card is seated properly and I am having this same error on my Galaxy S4. I think it began around the time I got the last update from U.S. Cellular but I'm not positive on the exact timing. I've tried popping the card in and out but that hasn't helped. I rebooted as well but the problem persists. Sometimes the phone will recognize the SD card, but usually it can't see the card. Also, I'm using a Sandisk card that I know to be good because it works in another phone.

    If anybody finds a solution, I'd love to hear about it. Maybe it's something that will get fixed in the next update.
    05-10-2013 09:15 PM
  5. GMJeff's Avatar
    If you check the forums here, there are multiple posts about SanDisk memory cards not being reliable in Samsung devices. It appears that it may live on in the S4.

    I have been using Samsung cards in my Samsung devices for a few years now and have not had the issue. These include Galaxy S2, S3, S4 (now), Note and Note 2 and a Galaxy Note 10.1.

    Sent from my SAMSUNG-SGH-I337 using Tapatalk 2
    05-10-2013 10:33 PM
  6. Pakilad's Avatar
    i am having same problem with my 32GB Kingston SD card in my GS4......and i really am fed with this issue...my last phone GS3 had same issues
    05-11-2013 04:03 AM
  7. TXlady73's Avatar
    My S3 had this issue so I upgraded to the S4. I've had it 72 hours and now it is doing the same issue. I used a Lexmark 16G and a Sandisk 32G. The errors stated the SD card was removed unexpectedly but it was properly inserted, removed and reinserted, restarted phone etc, now it doesn't even see the card. The cards work fine in other phones and my PC. It reads all my SD cards that are under 16g. Seems to a Samsung issue. Unfortunately a very common one.
    05-15-2013 10:10 AM
  8. bswangolf's Avatar
    Got my gs4 a few weeks ago. I got the samsung 64g card for it. I can see I have the. Sd storage when I check the settings. But I cant figure out how to get stuff to the card? I never get. "Save as" so when I save stuff it keeps saving on the phone and not on the card? And haven't found where I can send to the card or share with the card?
    05-17-2013 10:10 PM
  9. bswangolf's Avatar
    Any help?
    05-19-2013 04:17 PM
  10. Paul Caballero's Avatar
    Hi guys. I had the same issue with my GS4. I bought the GS4 the day it came out for ATT. I went online and purchased the Sandisk 64gb from Amazon, received the card a few days later, transferred my files and everything seemed fine. The next day when I tried looking at photos it started doing the same thing you guys are experiencing after 3 days of restarting, mounting, discounting, I was pissed. This was killing the joy of having switched from the iPhone to Galaxy. I went to the ATT store and they told me that they have had similar issues and that sometimes the cards are faulty. So I called Amazon and told them what was going on and the card was faulty and they sent me a new one at no cost with a shipping label to return the old one. I received my new card and held my breath as I installed it. That was a week ago, I haven't had a problem yet and I'm loving my phone again. Good luck guys!

    Sent from my SAMSUNG-SGH-I337 using Android Central Forums
    05-19-2013 04:33 PM
  11. turtdigital's Avatar
    It tells me everything is wrong with my 64gb sd card its damaged safe to remove or try to reformat but the card works perfectly fine in every other device
    05-31-2013 11:16 AM
  12. turtdigital's Avatar
    First go in settings. Then go to nearby devices and it should have a saved to option or something like that. Thats the first phase to make sure all iternet downloads go to the card press the internet button then go in menu to settings to content settings and change default storage u may have to reverse the order of steps
    05-31-2013 11:26 AM
  13. kuz911's Avatar
    Hi. Ive bought my Samsung Galaxy S4 on Three mobile. 16gb versions of the S4 only have 8gb free space, which is very less. External SD card supposed to benifit. But in this case most S4 are faulty. Im having the the same issues. I have 8GB sd card which worked 100%. I added 100 songs, took 5 photos, 2 10sec videos. But suddenly stopped working. On notification it said Safely remove.....etc. Its not reconising my memory sd. But it works perfectly on my Samsung tab 10.1. I bought a new 16gb sd card. It worked perfectly but after 2 days, I had exactly same problem. SAMSUNG NEED TO SOLVE THIS ISSUE? IM VERY DISSAPOINTED. IF ANYONE KNOWS HOW TO FIX THIS ISSUE. PLEASE HELP ME?
    05-31-2013 11:29 AM
  14. Joe_Perone's Avatar
    Not to be condescending or sound jerky at all, but Yyou have to format the card within the device to create the right partitions for the S4. I did this on my ADATA 64GB card when I had got it, and to this day I have had no problems. It's been more than perfect!
    Steven Rogers2 and whodunit like this.
    05-31-2013 12:57 PM
  15. gollum18's Avatar
    The whole point of needing special formatting for a 64gb to work is because they all ship formatted to a Microsoft proprietary format (exfat) which Google doesn't want to license, so android doesn't support it period.

    Most Android phones won't recognize a 64gb card at all. Best thing to do is to stick it in a windows 7+ pc, not mac or Linux (as neither of them support it either) and format it to ntfs.

    Sent from my SPH-L710 using Tapatalk 2
    05-31-2013 01:47 PM
  16. lauraplane's Avatar
    I am having some issues with mine too. I hadn't formatted it at first but I have done that now. It works fine but after a restart I get a message that says the SD Card appears to be damaged. I restart again and it works fine. It is an annoyance for sure but I guess I can deal with it. I got the Sandisk 65gb SD card and I am on Verizon.
    06-05-2013 12:36 PM
  17. shanev02's Avatar
    Welcome to the world of Galaxy. I hade the same problem with my S3, it ended up frying the card. I bought another card, different brand, starting doing the same thing. Stupid me, I bought a S4 because I actually love the phone and now it is doing the same thing. If you want the solution ....there is no solution. I've trawled all over the web and tried every solution posted, might work for a while then the problem comes back. The silence from Samsung has been deafening. Might as well just get used to it and make sure you back up everything on your card!
    Zeno Koroknai likes this.
    06-06-2013 02:52 AM
  18. 09kitty23's Avatar
    For alot of those peeps that said Fat32 fixed the issue which I am sure you guys will find all over the net. This is what I have

    Samsung Galaxy S4 brand new. Sandisk 64GB class 10 with formatted partition fat32. Formatted for countless of times and still breaks like nobody's business.
    06-10-2013 01:00 AM
  19. Leptonite's Avatar
    I've got the Sandisk 64GB card also. Packaging specifically says its suitable for Android devices so I presumed it was correctly formatted.
    Problem only seemed to happen after I caopied a lot of media to it. Card got hot and S4 starts loosing it.
    I'm now doing a windows full format, will reinsert to phoen and do a phone format and see what happenes.
    Could this issue just be caused by the MicroSD card containing media files that Android doesnt recognise?
    06-13-2013 03:59 AM
  20. Leptonite's Avatar
    And another thing - I've taken the 64GB card out and the S4 reports that in Devikce Memory I have 97GB used in applications and 12GB used in Pictures,videos - but also says phone only has 9.15GB Total space. Samsung - whats going on????
    06-13-2013 04:05 AM
  21. Joe_Perone's Avatar
    All of a sudden today, I woke up and my Adata memory card wasn't being read. I got a message on the phone that said my card was ejected, and I knew it broke. Computer doesn't read it either. I guess it's going back today! It worked for 21 days, and today it konks out. Oh well, back to the store for another one.
    06-15-2013 09:55 AM
  22. Muhamad44's Avatar
    Me too. Same problem with 32gb sd card. Sometimes I copy photos or videos to the sd card and doesn't open or if open the file is damaged. Can't move files from device storage to sd Card. It says cannot moving the file.

    Sent from my GT-I9500 using AC Forums mobile app
    06-20-2013 04:07 AM
  23. notyourchevy's Avatar
    I'm having the same problem with my 32gb sd card worked fine for two weeks then my S4 started saying sd card removed unexpectedly. When I took it out and put it in my win7 computer it told me it was damaged just like my S4. Then the next day I put it back in my computer and it was working again. I contacted samsung they told me to try another card and get back to them. Well that wasn't smart cause it did the same thing to the new card. Thanks samsung for costing me two sd cards. Is the problem the size cause now I have a 1gb card in my S4 and it works fine. Why can't we get any answers?
    06-20-2013 09:18 PM
  24. doomslayermax's Avatar
    i had the same issue i had a Samsung S4 with a Samsung 8gb micro SD card , one day it disappeared in the phone , i tried everything to make the phone pick up back up i inserted reinserted it nothing , so i read a post above about formatting the card , which i did even though i had heaps of stuff on the SD card , so i formatted it to ntfs nothing worked kept coming up as broken SD card , so i reformatted it to fat32 then inserted it and clicked on the error message it gave me a option to format it and so i did and now its fixed hopefully its fixed not something that is temporary , but its weird why this has happened out of no where but any who i hope this helps you's all.
    06-21-2013 07:59 PM
  25. vogelito's Avatar
    Hi all, first-time poster here. Also having issues with "SD card unexpectedly removed" and then immediately remounted. Didn't have problems when phone was new (5-6 weeks ago), but now it seems to be getting worse and worse. Galaxy S4, PNY 16 MB class 10 micro SD card.

    Call me crazy, but... I was convinced this was not a mechanical problem (pulling card out, blowing in slot (a la NES), cleaning contacts, etc) didn't seem to make a difference.

    But I was just playing around a bit more with the phone. I actually had the back cover *off* with the phone on. Lightly pressing down on the SD card (in the middle of the card, or at the contacts, or wherever) was giving me this "SD card unexpectedly removed" error. As soon as I let go, the SD card was found again. Every time, 20 out of 20 times.

    I tried stuffing a piece of index card (cut down to the right size) in the slot between the SD card and that outer metal/blue-tape piece of the slot to see if that would create a better electrical contact between SD card and phone. That made no difference. *But*, when I put the index card on the under-side of the SD card (between the SD card and the phone, careful to not insert the paper too far as to block electrical contacts), this seemed to fix the problem. I'm unable to get the "unexpectedly removed" message anymore (for the last hour, at least). (Easier to insert the index card if you remove the SD card and then put both (index card/SD card sandwich) in together.)

    Can anyone else with this issue see if they can reproduce what I've said here? Was the solder job too weak in the manufacturing of this phone? Or do I happen to just have a completely different problem (mechanical contacts, vs everyone else with a software bug)?? Will update if I get this "unexpectedly removed" error again...

    06-22-2013 09:32 PM
285 123 ...

Similar Threads

  1. Galaxy S4 SD card issue
    By JamesM1 in forum Samsung Galaxy S4
    Replies: 70
    Last Post: 10-18-2014, 02:48 PM
  2. Cannot move apps to SD card with Samsung Galaxy S4
    By nkboy9 in forum Samsung Galaxy S4
    Replies: 89
    Last Post: 11-11-2013, 09:46 AM
  3. Replies: 55
    Last Post: 10-31-2013, 09:41 PM
  4. AT&T Galaxy S3 SD Card issues..
    By joe.kent in forum Samsung Galaxy S3
    Replies: 38
    Last Post: 03-02-2013, 05:57 PM
  5. SD card issues
    By vbsoulpole in forum Software Development and Hacking
    Replies: 1
    Last Post: 02-07-2010, 03:04 AM