1. Ryan Gehret's Avatar
    Hello all,

    I'm relatively new to the Android world; I purchased my Galaxy S4 two months ago. I rooted it, because the advantages sounded good to me. Well, a couple days ago I heard about a firmware update, so I attempted to update (not knowing rooting basically breaks OTA updates). I was able to proceed and download the update, but the install failed, so I tried again. No dice, it said my software was up to date, when I know for a fact that it was and is still not updated. I'm on I337UCUAMDL, and the newest is I337UCUAMF3.

    I did a factory reset, completely wiped the phone and reflashed the stock ROM. Still couldn't update. Factory reset two more times, still nothing. I had AT&T replace my phone with an entirely new handset and I STILL can't get the update.

    I've tried Kies aswell, it says the same thing it does on my phone, that my software is up to date. I know at least three people with the exact same S4 as mine and they updated on the spot, in no time at all. I'm completely puzzled as to why I can't; the only thing I can think of is my Google Account might be causing an issue. Anyone know what's going on here?

    I appreciate any help with this. Thanks
    07-15-2013 08:41 PM
  2. gollapudis's Avatar
    I'm in the same boat.. cant update to I337UCUAMF3.. Everytime I check for an update it says my current software (I337UCUAMDL) is up to date.
    07-16-2013 12:24 AM
  3. Ryan Gehret's Avatar
    I was able to flash! I downloaded the .cfg file from this link [GUIDE][I337UCUAMF3][STOCK][NEUTERED] MF3 OTA Update - Keep Recovery and Root! [7-12] - xda-developers

    Be sure to SCROLL DOWN for the untouched update. Download that, change the file name to "update" and the extension to .zip, put it on your SD card, boot into recovery and select "Install update from external storage."

    It installed fine and now I'm on the latest firmware!
    07-16-2013 02:08 AM
  4. davidphan1215's Avatar
    Did you download the one that says unaltered patch?
    07-16-2013 06:59 PM
  5. Nathan Gargano's Avatar
    He did. He went down the page to the original software update.
    07-18-2013 03:03 PM
  6. smerchn's Avatar
    Did you guys keep root?
    10-13-2013 08:21 PM

Similar Threads

  1. I need help regarding Galaxy S3 mini Internal storage problem.
    By chester47 in forum General News & Discussion
    Replies: 5
    Last Post: 04-04-2014, 11:01 PM
  2. Is the Galaxy S 4G worth switching from an iPhone? is it good?
    By galaxyfreak95 in forum T-Mobile Galaxy S 4G
    Replies: 4
    Last Post: 10-07-2013, 09:29 AM
  3. Best way to get my Galaxy S4 data, apps, layout etc to a new Galaxy S4
    By dankduke1 in forum AT&T Samsung Galaxy S4
    Replies: 4
    Last Post: 07-16-2013, 06:16 PM
  4. Takes forever to download from the play store.
    By KingGinger55 in forum LG Optimus G
    Replies: 1
    Last Post: 07-16-2013, 11:23 AM
  5. Samsung Galaxy s3 wifi and bluetooth problems
    By Dezdannhauser in forum Samsung Galaxy S3
    Replies: 1
    Last Post: 07-15-2013, 05:09 PM