1. Stefano Giovannini's Avatar
    Hi - I just have purchased a Nexus 7. I went to the google play website and I used to be able to see all my devices individually and see what apps were installed on each device and all the apps in my library. It made it easy to add apps to a new device. Now I just see all the apps installed but not broken down by device, so I have to click on each individual app to see on which device they are installed. It is a more convoluted process, and I would like to see on the website at a glance which apps are installed on each device I own. Did something change or something I am missing? I also can't log in do the device manager with Chrome but I can with Safari. Mac OS X10.8, Android 4.1
    thanks

    stefano
    08-09-2013 02:38 PM
  2. B. Diddy's Avatar
    There was a big change about a month or two ago in the Google Play website UI. You're not the first to complain about it. Hopefully they'll bring back the functionality some time in the future. It wouldn't hurt to contact them directly with your concerns. Go to this website, and click on the "Contact Us" button: https://support.google.com/googleplay/
    08-09-2013 04:50 PM
  3. Stefano Giovannini's Avatar
    thanks -
    I am trying to write to support but I kep getting an error message:
    "Please provide us with more details by adding more text to the issue description field, then submit your request again.
    If you have questions about any of the following topics, the help center articles listed below may help answer your questions.
    We couldn't submit your form yet. Please fix the fields above and make sure you're logged in to your Google Account."

    I was logged in.
    Anyway it is confusing to see all the apps as installed but with no way of knowing at a glance if installed on one or more devices.
    08-09-2013 05:20 PM
  4. B. Diddy's Avatar
    Are you sure you clicked "Contact Us" at the upper right, rather than "Send feedback about the Help Center" at the lower right? When I click "Contact Us," it asks me to select various choices pertaining to the issue--finally, it gives some suggested links to answer questions, but there is also a "Call Us" button at the end, which is what you probably want to press.
    08-09-2013 05:39 PM
  5. Stefano Giovannini's Avatar
    Yes I did exactly what you described. I get that error when I press "Call Us"
    08-09-2013 05:45 PM
  6. B. Diddy's Avatar
    Strange. It just worked for me. I typed in a 400 character message describing the issue that we've been discussing, then pressed "Call me," and it was accepted. So if they call me back, I'll do my best to convince them to fix it!
    08-09-2013 05:54 PM

Similar Threads

  1. Android Device Manager available
    By Jon Sid in forum Google Nexus 4
    Replies: 3
    Last Post: 08-12-2013, 12:40 PM
  2. wifi not connected
    By theelady in forum Samsung Galaxy Tab 3
    Replies: 1
    Last Post: 08-10-2013, 01:51 PM
  3. Asus MeMO Smart Pad Bluetooth on Mate 15-64
    By randiroo in forum ASUS EeePad MeMo
    Replies: 0
    Last Post: 08-09-2013, 02:30 PM
  4. Nr.1 Anti-Theft app, and I tried them all!
    By MillardMynatt in forum Android Apps
    Replies: 0
    Last Post: 08-09-2013, 01:29 PM
  5. Camera not functioning , advice if you could
    By Minuno in forum Acer Iconia A700
    Replies: 0
    Last Post: 08-09-2013, 01:23 PM
LINK TO POST COPIED TO CLIPBOARD