1. micheal datoc's Avatar
    just recently i noticed that when using my play store to search for an app, i cannot search anything...it always says "no results found"... i already cleared my cache for play store app but still i ended up with the same thing...what can i do??? i am living here in macau...any help???
    09-19-2013 05:41 AM
  2. AMOCO's Avatar
    You could try factory resetting your phone.

    Sent from my N9100
    09-19-2013 05:45 AM
  3. srkmagnus's Avatar
    Log out of the account then log back in and see if that works. Can you browse the selections via the app categories?

    Posted via Android Central App
    09-19-2013 08:09 AM
  4. nelmart15's Avatar
    I'm having the same issues, I've log out and doesn't work. I can download apps normally except while doing a search. I have a Galaxy Note 2. Any help will be very much appreciated.
    09-20-2013 05:59 AM
  5. NKK64's Avatar
    I have similar problem. Search fails from all my home or office PC-s too. It fails even from freshly installed browser irrespective whether I'm logged in/out to Google.

    Today I checked with my colleagues PCs. 3 out of 4 failed. Only one macbook laptop worked - rather funny.
    09-23-2013 04:55 AM
  6. srkmagnus's Avatar
    Since multiple people are having this issue, and it seems to be a very recent issue, it may be an issue on Google's end. Has anyone tried reporting a problem with Google?

    If it's a Google problem expect a resolution soon...hopefully.
    09-23-2013 09:55 AM

Similar Threads

  1. Replies: 1
    Last Post: 09-21-2013, 02:44 PM
  2. help: google play store can not search anything
    By legarcon in forum General Help and How To
    Replies: 9
    Last Post: 09-20-2013, 02:12 PM
  3. Google play country restrictions continue after all attempts
    By rogier_ssx in forum Google Play Store
    Replies: 1
    Last Post: 09-20-2013, 10:40 AM
  4. Need help - play store not working
    By ewissell in forum General Help and How To
    Replies: 1
    Last Post: 09-18-2013, 09:26 PM
LINK TO POST COPIED TO CLIPBOARD