1. secrecyguy's Avatar
    I just recently got myself a Samsung S 3. I am very happy with it. The only complaint I have is the reception. I found out it's because it's trying to go 4G and sometimes it does not get good reception. I later found an article that Sprint working on their 3G and 4G networks so that probably explain another reason why I don't get good reception.

    So my question is, is there a way to force the phone to use only 3G? I also like the option to go back to 4G when I am in a good reception area.

    Thanks for any help!
    12-12-2013 11:45 AM
  2. UJ95x's Avatar
    Go to Settings > Connections (Should be the first by default) > More Networks > Mobile Networks > Network Mode and select the option without LTE
    B. Diddy likes this.
    12-12-2013 11:54 AM
  3. secrecyguy's Avatar
    Go to Settings > Connections (Should be the first by default) > More Networks > Mobile Networks > Network Mode and select the option without LTE
    Thanks! That works!
    12-12-2013 09:15 PM
  4. UJ95x's Avatar
    No problem

    Posted via Android Central App
    12-12-2013 09:17 PM

Similar Threads

  1. how to swype ?
    By shravee in forum Samsung Galaxy Tab 2
    Replies: 7
    Last Post: 01-03-2014, 10:23 AM
  2. N7 not showing up on laptop.
    By spackmanstephen in forum Google Nexus 7 Tablet (2013)
    Replies: 9
    Last Post: 12-14-2013, 12:38 AM
  3. Replies: 3
    Last Post: 12-12-2013, 12:13 PM
  4. Pinch-to-zoom and volume-to-zoom not working
    By sconti555 in forum Android 2.3 Gingerbread
    Replies: 0
    Last Post: 12-12-2013, 11:11 AM
  5. Film on camera out of box?
    By justlaxin13 in forum Moto X (2013)
    Replies: 1
    Last Post: 12-12-2013, 11:05 AM
LINK TO POST COPIED TO CLIPBOARD