1. 2Fredsone's Avatar
    I have developed a real problem downloading apps.
    When I go to the play store select apps>type the app name>select the app I want>select download>accept permissions then the pre-download process starts (the step where the download progress bar appears) but it never steps to the actual download of the data (I actually tried leaving it for 2 hours and it sated at the pre-download process).
    I do have a slow data connection, but I reason that if I can get to the actual download step then the data speed must be sufficient (it always was).
    Any Ideas?

    01-05-2014 02:16 AM
  2. NoNexus's Avatar
    I am always on a great connection and I have it hang once and awhile as well. I think that if it gets disconnected at any point, it just hangs.

    Short of that, I would try to clear cache and data on the play store to see if that helps
    01-05-2014 02:44 AM
  3. B. Diddy's Avatar
    Welcome to Android Central! Make sure you haven't disabled Download Manager for whatever reason. Go to Settings/Apps/All, and look for Download Manager. If you don't see it, scroll all the way down, and see if it is among the Disabled apps. If so, tap it, then tap Enable.

    On Jellybean and KitKat, there may be a separate Disabled category in Settings/Apps.

    Posted via Android Central App
    01-05-2014 03:09 AM
  4. 2Fredsone's Avatar
    Thanks for the suggestions... unfortunately there wasn't any improvement
    I have given up on the plastore app and am now using Firefox to get to the playstore and download what I wanted.

    01-05-2014 10:22 PM
  5. B. Diddy's Avatar
    What device do you have? It may be worth wiping the system cache partition in the Recovery Menu, if that's an option.
    01-05-2014 11:23 PM
  6. 2Fredsone's Avatar
    Hi B. Diddy
    I have a Zopo 990.
    I am not sure what the system cache partition in the Recovery Menu is... I am guessing that it is not the Cached data function in the System>Storage options.
    I am wondering if the problem was caused by a number of app updates which occurred 3 days ago.
    I had backed the 990 up with helium, Am I correct that Helium also backs up apps and app data?
    Unfortunately I cant get helium to work on my computer at the moment, so I am looking into that.... Phew don't I love tech :-)
    01-06-2014 12:05 AM
  7. 2Fredsone's Avatar
    I have found the "Wipe Cache Partition" function.
    Are there any concerns with wiping the cache partition, or is it safe(ish)? :-)
    01-06-2014 12:28 AM
  8. B. Diddy's Avatar
    The system cache partition is where various temporary system data is stored, including logfiles, downloaded installer files from Google Play, and other stuff. It's not normally accessible from the main user interface. Sometimes, this data that builds up might bog things down, or cause some problems outright. Wiping the system cache partition can correct some of these problems, and will not cause any loss of personal data or settings. So give it a try--just make sure you're choosing "wipe cache partition," not "wipe data/factory reset."
    01-06-2014 01:26 AM
  9. 2Fredsone's Avatar
    Thanks for the input B. Didy.
    I have cleared the Cache Partition and have just downloaded an app via the Play Store, so it looks like your tip worked, danke.
    It was all very simple really wasn't it :-)

    P.s. Should someone else come looking for the same solution on a Zopo ZP990, I found the "Recovery Menu, Wipe Cache Partition" function with the following steps;
    1) Power down the ZP990
    2) Connect the 990 to USB charger/computer
    3) Restart the 990 by holding the power button and the volume UP rocker.

    Note; restarting the 990 by holding the power button and the volume down rocker will start the device in Chinese Recovery Menu mode. So if you cant read Chinese you will not know which of the options will return the 990 to its normal functions (I got lucky and didn't inadvertently select the "wipe data/factory reset" option).
    B. Diddy and JoeBtfsplk like this.
    01-06-2014 03:38 AM
  10. B. Diddy's Avatar
    Thanks--it is extremely helpful that you posted the process of getting to the Recovery Menu on your phone. When I did a quick search beforehand, I couldn't find that easily. Good job!
    01-06-2014 03:50 AM
  11. JoeBtfsplk's Avatar
    I've been having problems updating for a long time with my Galaxy Nexus (running CM11) and clearing the Download Manager didn't help. But going to TWRP recovery and (with trepidation) clearing cache and Dalvik cache cleared it up. Many thanks.
    10-14-2015 02:40 AM

Similar Threads

  1. Replies: 7
    Last Post: 01-31-2014, 01:29 PM
  2. Galaxy Note 3 - NFL Icon missing, app still installed and working
    By HMArnold in forum Samsung Galaxy Note 3
    Replies: 2
    Last Post: 01-07-2014, 05:05 PM
  3. Replies: 2
    Last Post: 01-05-2014, 05:52 PM
  4. Moto x and word feud
    By Tony Rizzo in forum Moto X (2013)
    Replies: 9
    Last Post: 01-05-2014, 02:54 PM
  5. Replies: 4
    Last Post: 01-05-2014, 09:20 AM