1. moneymoh's Avatar
    I previously unlocked the bootloader and rooted my Moto G. The kitkat update was released today, when i tried to update the phone powered off and said something like "Updating...". The bar got to about 60 pct and said "Error!", then the phone rebooted, and after a short time a pop-up said, "The Update Failed!".

    I tried resetting my phone, unrooting my phone, same problem. I tried using Motorola Device Manager to update, and it said
    "There are no updates for your device at this time.
    Current Version: 14.81.1.falcon_umts.Telus.en.CA".

    SOLVED (This only works if you have an unlocked device):
    Step 1: I Downloaded My Stock Firmware here: http://sbf.droid-developers.org/phone.php?device=14

    Step 2: I Downloaded fastboot and mfastboot (you need both) from here, https://docs.google.com/file/d/0B_ni...BfbXFlUk0/edit

    Step 3: I unzipped my stock firmware so all the files were in the ElementalXDesigns-MotoX-Tools folder

    Step 4: I installed the drivers for my Moto G, including Motorola device manager, not sure if that was needed though

    Step 5: On my Moto G i went to Settings, About Phone, and tapped Build Number 7 times until i became a developer

    Step 6: I went into the newly found Developer options and turned USB Debugging on, I connected my USB cable to my PC, and a popup on my phone asked me if i wanted to allow access to my PC, i allowed it

    Step 7: I held shift on my keyboard and right-clicked inside the ElementalXDesigns-MotoX-Tools folder and selected [Open Command Window Here]

    Step 8: I typed in the command window "adb devices" to check if my everything was functioning properly and my device was connected, the response in the command window was

    List of Devices attached
    TA883056TR device

    Step 9: I typed in the command window "adb reboot bootloader" to boot my phone into fastboot

    Step 10: I opened the .xml file (using notepad or internet explorer) that i previously extracted from my firmware package, in my case
    It had steps listed under <steps interface="AP"> which i put in to CMD (If you dont see it like this, open it with internet explorer)
    Example first step was: <step operation="flash" partition="partition" filename="gpt.bin" MD5="85bb9a8cc1747d87547c4a77aa389667" />
    So in the command window i typed "fastboot flash partition gpt.bin"
    For every command you have to type fastboot before you type the step operation, partition, and filename, EXCEPT for the system.img ones or one, for those instead of typing fastboot before, you type mfastboot, example:
    <step operation="flash" partition="system" filename="system.img_sparsechunk.0" MD5="e472e9ffb293637081b4c424eb833ebf" />
    So i typed in my command window: "mfastboot flash system system.img_sparsechunk.2"

    Step 11: Once i was done inputting all of the commands in order, i rebooted my device, i tried the update like normal, and it worked!
    01-14-2014 11:31 PM
  2. mrsmumbles's Avatar
    You could try setting the date ahead by a few days and see if you get the update again.

    Sent from my Nexus 5 using Tapatalk 2
    01-14-2014 11:34 PM
  3. moneymoh's Avatar
    Well i can get the update fine, i just go into Settings, About Phone, System Update, and the download starts. The problem is the update downloads, begins installing, but never finishes, it gives me the "Error!" message, boots up, and after a short time a popup appears saying The Update Failed!
    01-14-2014 11:41 PM
  4. mrsmumbles's Avatar
    Factory reset. Back up your data beforehand.

    Sent from my Nexus 5 using Tapatalk 2
    01-14-2014 11:43 PM
  5. mrsmumbles's Avatar
    Plus, you may only be having trouble today. Sometimes if you just wait a day or two and try again it works fine. In fact things like that happen to me all the time (not necessarily related to my phones).

    Sent from my Nexus 5 using Tapatalk 2
    01-14-2014 11:44 PM
  6. moneymoh's Avatar
    I tried a factory reset, I really don't think this will resolve itself with time unless Motorola Device Manager was slow to get the update. But even if it does get it, there's no reason to think updating it from my computer would work, it probably uses the same process after uploading the file to the phone.
    01-14-2014 11:48 PM
  7. mrsmumbles's Avatar
    It's worth a try... :-)

    Sent from my Nexus 5 using Tapatalk 2
    01-14-2014 11:49 PM
  8. moneymoh's Avatar
    Still having the same problem, not resolved yet, going to try some different things today
    01-15-2014 03:37 PM
  9. mynameis's Avatar
    I don't really know very much about rooting and there are a lot of others here that know a great deal more about it so hopefully they will see this. I'm sure they will. But I'm pretty sure you are NOT supposed to update your phone if you have rooted your device. I'm pretty sure it can brick it.

    Now, please. Anybody correct me if I'm wrong for I could be. That's just something I feel like I read somewhere. So anybody else's answer will be better.

    That's just what I think. :/

    Sent from the mother ship
    mrsmumbles likes this.
    01-16-2014 12:01 AM
  10. mrsmumbles's Avatar
    I think rooting is OK but not if you flashed a ROM. I'm not sure either because I never rooted yet.

    Sent from my Nexus 5 using Tapatalk 2
    01-16-2014 07:39 AM

Similar Threads

  1. Camera Pictures deleted after Installing Kitkat
    By Morfie in forum Motorola Droid MAXX
    Replies: 14
    Last Post: 09-14-2014, 10:45 PM
  2. S3 Stuck on 4.1.1 - any way to force an update?
    By d1c1ple in forum Verizon Galaxy S III
    Replies: 7
    Last Post: 01-29-2014, 02:14 PM
  3. MotoRoot & 4.4 update
    By newbeginning828 in forum Motorola Droid MAXX
    Replies: 7
    Last Post: 01-24-2014, 06:22 PM
  4. Sprint Note 2: 4.3 update not taking
    By jameyg03 in forum Sprint Galaxy Note 2
    Replies: 2
    Last Post: 01-19-2014, 11:07 PM
  5. Looks like there's going to be an all white Moto G ?
    By Harvinder Sunila in forum Moto G (2013)
    Replies: 2
    Last Post: 01-15-2014, 07:21 AM