1. Cody Wright1's Avatar
    First off here is my tablets information
    name: Cobalt tab s800
    model #: SW-ARMM8S
    android ver: 4.0.4/ICS

    don't confuse this name with the Archos 80 cobalt they are very different

    I bought a new, prerooted android tablet online about two weeks ago and I was very happy with it for a little while anyway. I know for sure that the problem didn,t exist until after I uninstalled some unimportant system apps (google books/magazines/music/maps etc.). Now everytime I reset my tablet all user apps and app data are wiped and my internal app storage is 0.00mb. The first thing I tried was a factory data reset but of course that didn't help since my device is basically doing that everytime it loses power anyway I also tried factory data resetting from recovery that didn't work either.

    I was stuck like this for a while until I realized I could use adb to push a file manager into system/app. I had a very hard time finding drivers for my tablet because it is so obscure and off brand but eventually i found something called universal adb driver installer which worked and I was able to mount sytem as rw and push es file explorer and rom toolbox pro onto my android.

    So luckily I had installed busybox before all of this happened and I have another rooted android device so i can download apps with it, back them up, transfer them over to my tablet's internal storage and use es file explorer to copy the apk into data/app. My tablet says that there is 0.00mb of app storage even though it is reporting that 128mb is being used by user apps. I have also figured out that I can backup all of my user apps and app data by copying everything in data/app and data/data into my sd card. So if my tablet ever restarts or dies I can use rom toolbox to mount my tablet as rw and then use es file explorer to copy all of my data back into place and then use rom toolbox to do a fast reboot (which doesn't turn off the power and so my data remains intact)
    and voila all of my data is restored.

    But doing all of that is a hassle and a half just to keep my data intact and did I mention that anytime I make even the smallest settings change in any of my apps I have to then backup that apps data which is extremely time consuming and error laiden. I have tried to change the permissions for data/data and data/app but all in vain because both of these folders are completely formatted anytime my device loses power.

    There is no custom recovery or custom roms available for this device.
    02-20-2014 08:55 PM
  2. zedorda's Avatar
    Why haven't you return the unit?
    02-20-2014 09:22 PM
  3. Cody Wright1's Avatar
    I've already thrown away all of the packaging besides it's only a simple software issue and I'm already rooted so there should be some quick fix unless it's a partition issue which I believe it is.
    02-20-2014 09:40 PM
  4. rod4x4's Avatar
    Your symptoms match bad memory chips. They report ok, but in fact not! I would say your device memory is no longer useful. I sincerely hope you have a backup and did not pay too much for this device. In the long run you are better off paying for quality and good support.
    02-21-2014 08:02 AM
  5. Cody Wright1's Avatar
    I really don't think that it's a hardware problem and the problem is just the opposite of what you said my device thinks that there is no user application memory when in fact there is plenty of available memory. I just need to find some way to fix the data partition without completely installing another rom.
    02-21-2014 09:43 PM
  6. rod4x4's Avatar
    The system may say you have plenty of memory, but that memory may not Be functional. I had the misfortune of having several 32gb SD cards that appeared functional as 32gb but played up after adding more than 2gb. As a test only restore half your data and see if you system mis behaves.
    02-21-2014 11:01 PM
  7. Cody Wright1's Avatar
    I'm talking about internal application storage not external sd card storage and once again my problem is the opposite of what you are saying my system says I have no memory but the truth is that the data partition has somehow become corrupted and my tablet is unable to allocate the memory so it thinks that there is 0.00 MBs of memory
    02-25-2014 09:12 AM
  8. Rukbat's Avatar
    The Cobalt S800 seems to be one of those Shenzhen Specials - made as cheaply as possible by a company that changes its name the day after it makes its first (and only) shipment. (As opposed to the quality equipment coming out of the same city - stuff like Samsung, SanDisk and Logitech). You could very well have defective internal memory. We're not going to be able to diagnose it by discussing it here - it has to go into a good shop for diagnosis and an estimate. (Or you might try to see if the place you bought it from will exchange it without the packing material, or charge you a few dollars for the material.)
    02-25-2014 04:49 PM

Similar Threads

  1. How does Helium work?
    By ruhban in forum General Help and How To
    Replies: 30
    Last Post: 07-02-2016, 05:07 AM
  2. Unlocking and Rooting HTC One (Verizon)
    By Justin Moore5 in forum Legacy Android & Other OS's
    Replies: 27
    Last Post: 05-25-2015, 09:59 PM
  3. Just got a Droid Ultra, any tips and advice?
    By rudyalexc in forum Motorola Droid Ultra
    Replies: 11
    Last Post: 04-24-2014, 03:58 PM
  4. [FREE APP][2.3.3+] Chemify: Chemistry Tools
    By joeb3219 in forum Android Apps
    Replies: 2
    Last Post: 02-27-2014, 05:54 PM
  5. Bootloader DO.11 message. Android Verizon Droid 2 Global A956 QWERTY
    By savaici in forum Legacy Android & Other OS's
    Replies: 0
    Last Post: 02-20-2014, 07:32 PM