1. cptnsmelly's Avatar
    Alright, I'll write the solution if you guys help me fix this. I forgot to with the other thread.

    Here's my issue:

    I tried to get CM11 on my LG G2 on Bell Canada's network and I really messed it up. It turns out that Canadian carriers use the stupid D803 version of the LG G2 which looks exactly the same as the D802 version but runs different roms or something like that. So I flashed a D802 rom and screwed up my D803 phone... I can no longer get into recovery, adb doesn't see my phone, but download mode works (though I have no idea how to use it). I even tried the "Get out of Fastboot" tutorial and it didn't work because when I get to the point where I have to choose "Android" under "other devices" in Windows 7 and my G2 is showing up as "SAMSUNG Android Phone" and under that it says "USB Modem Phone ADB Port". The latest drivers for LG are installed so I have no idea what's going on.

    I also tried using LG UPTestEX which is supposed to let you flash .kdz files or whatever they're called. I got a Bell original rom file for LG G2 and put it in. When I followed the tutorial for flashing .kdz through the LG utility I can make it up to the point where you're supposed to get a popup asking for your language and country. The language and country bubble never pops up! So I don't know what's going on there.

    So now my phone boot loops to little rows of words at the top of the screen: [650] Fastboot mode started [700] udc_start() and it's stuck like that. I can get to download mode with USB and pluging in while holding volume up, but that's the only other thing I can do.

    Also, my PC is still seeing my G2 (in Device Manager) as "Samsung Android Phone" and under that "USB Modem Phone ADB Port". Also, when I open CMD and type "Fastboot devices" it says "? fastboot" I'm guessing that means it knows there's a device but doesn't know what it is... Damn this is frustrating. I hope I haven't completely bricked my phone...
    Please, what can I do to fix this phone? I need a simple tutorial for a total noob like myself.


    Secondly, is there any way I can get CM11 on this Bell phone? I don't like LG's skin...
    UJ95x likes this.
    03-11-2014 12:31 PM
  2. cptnsmelly's Avatar
    Alright so I may be making some progress here... I'm going to write this out as I learn it. I opened cmd typed "fastboot" then typed "cd \tools" (this tells fastboot to look in my C: drive at a folder called "tools". There was no folder called "tools" in my C: drive so I made one. On the next line I typed "fastboot flash recovery boot.img" the part that says "boot.img" is just the name of the .img file you're trying to flash. I tried to flash a .zip before and it said "You cant, it's not an .img" so I extracted the .zip and it had a file called "boot.img" in it. Hence the reason I typed "fastboot flash recovery boot.img".

    So then fastboot did a bunch of stuff in the cmd window and ended with "finished!" so I'm here thinking "Great! I finally fixed it!"
    So next I typed "fastboot reboot" and my phone rebooted.... Back to the stupid fastboot screen...

    So now that I understand (at least a little bit) how to actually flash .img files to my phone with fastboot, how can I get my phone out of fastboot? I was hoping I was stuck in fastboot because my rom was messed up and flashing a .img file would fix it. I guess I was wrong. Most of this comes from me understanding about 5% of how flashing works...

    Help anybody?
    UJ95x likes this.
    03-11-2014 01:10 PM
  3. cptnsmelly's Avatar
    Chahk helped me out on another website! The guy is awesome. Here's what he said:

    "If your computer is able to recognize the phone while it's in Fastboot mode, you are half-way there. You will now need to flash a proper Recovery image, and then use the Recovery mode to flash a compatible ROM.

    It doesn't looks like ClockworkMod officially supports your version of LG G2 (d803). The other well known recovery is TWRP (short for Team Win Recovery Project). There are two different recovery images for d803 - Bell and Rogers. Go ahead and download the one appropriate for your carrier, and save it somewhere on your computer.

    Now do the following:

    Boot up your phone into fastboot mode, and connect it via USB to the PC.
    Open Windows Command Prompt, and navigate to wherever the fastboot.exe program is installed (e.g. cd c:\fastboot\)
    Issue the following command: fastboot flash recovery [path-to-img] where "[path-to-img]" is the full path to where you downloaded the recovery image (C:\temp\openrecovery-twrp- for example)
    Turn the phone off, diaconnect it from USB, and boot to recovery by holding the Vol Down+Power buttons, then as soon as the "LG" logo comes up release them and press & hold them again, and then on the screen press the Power button 3 times.

    You should be in TWRP recovery. Re-connect the phone to PC via USB, and now ADB tool should be working.

    You can now try to find the CM11 version for your phone, adb push it to your phone's memory while it's in Recovery mode, and then flash it with TWRP. I would also recommend performing a complete wipe via TWRP to clear out any residual files from your previous flashing attempts.

    Currently CyanogenMod does not officially support the Canadian variant (d803) of LG G2, but some people had successfully modified the d802's package. This involves extracting a file from the official CM11 zip, modifying it to include the d803 model, re-packing it into the zip, and finally flashing it. A different kernel is also required to be flashed right afterwards, and can be found here (you will need the AOSP based one.)

    Hope fully that fixes things for those of you who are total noobs like myself!
    UJ95x likes this.
    03-11-2014 04:14 PM

Similar Threads

  1. Help: Black screen after bootanimation [water damage]
    By tenjou_89 in forum Moto G (2013)
    Replies: 1
    Last Post: 06-12-2014, 03:13 PM
  2. Sprint LG G2: Status bar Icon help
    By Crupe in forum Sprint LG G2
    Replies: 4
    Last Post: 03-21-2014, 01:02 PM
  3. Nexus 7: Help with Keyboard/Language
    By jvsnyder99 in forum Google Nexus 7 Tablet (2013)
    Replies: 5
    Last Post: 03-14-2014, 03:10 PM
  4. Replies: 14
    Last Post: 03-14-2014, 01:47 AM
  5. Help with root
    By Qurlee in forum Verizon Samsung Galaxy Note 3
    Replies: 5
    Last Post: 03-11-2014, 02:12 PM