1. GlennFS's Avatar
    Good morning

    Have had an ongoing problem with error 403 in the Google Play Store.
    In this case, the issue seems to have arisen because I have historically used 2 google accounts to purchase apps. 'Account A' from 4 to 3 years ago, and 'Account B' from 3 years onwards.

    I now only have 'Account B' on my phone (N7000), however, some of the apps which I purchased with 'Account A' still appear as purchased in my Google Play Store, even although phone can be hard reset with no further 'Account A' reference. So I get this 403 download problem, although I wouldn't even mind just buying some apps afresh with 'Account B'. Also, maybe of relevance, the same card was used to purchase on both accounts.

    Is there a way I can 'clear' the original 'Account A' purchases?

    Any advice would be appreciated,
    03-22-2014 04:18 AM
  2. SpookDroid's Avatar
    Have you tried clearing Google Play cache/data from the App Manager? This would force Google Play to refresh the app list installed on your phone the next time you reboot.
    03-22-2014 04:34 AM
  3. GlennFS's Avatar
    Thanks for the reply. I cleared the data/cache as suggested for both Play Store and Services. Rebooted and unfortunately the same result. I had also formated the internal SD partition before I reflashed the ROM last night.

    The two accounts I mentioned are also on different emails. The only thing that links them whatsoever is my name and payment card.

    I wonder if the play store recognises the same payment details and assumes that there is no need to pay, even though the accounts are different (and cannot download).

    I'll try changing the card details to another and see if that makes a difference.

    Posted via Android Central App
    03-22-2014 07:14 AM
  4. Rukbat's Avatar
    Try looking for a Google contact number and calling them. The people on that end of the server have a lot more control over what it can do than we users do.
    03-23-2014 02:47 AM
  5. GlennFS's Avatar
    I'll try that thanks. Changing payment card made no difference.

    Posted via Android Central App
    03-23-2014 07:43 AM
  6. SpookDroid's Avatar
    Are you using any kind of software recovery software or backup after re-flashing the ROM? Or maybe, are the apps you're having trouble with already installed in the ROM? If so, that might be what's causing the issue...

    Are the apps you're having issues with listed as purchased through the Google Play WEBSITE on your 'B' account?
    03-24-2014 05:11 PM
  7. GlennFS's Avatar
    No backup software installed, and no backup folders.

    Logged in as account B. The website section of 'my orders' does not show the apps I want to install. However, the 'my apps' pages does show the apps as being installed, That were purchased from account A (and every other app I have ever installed and removed I think.)

    The app I am trying to install first is Picsay Pro, which is not included within the ROM on my phone. Having installed CyanogenMod stable build. Although stock ROM produced the same results.

    Get a new phone tomorrow, hoping that might be the solution. As the website Account A should have no reference to that phone.

    Posted via Android Central App
    03-25-2014 05:42 AM

Similar Threads

  1. Share Google Play, but not Gmail or other google services
    By hitchens97 in forum General Help and How To
    Replies: 2
    Last Post: 03-22-2014, 02:10 PM
  2. Google Music help
    By anthony1117 in forum Android Apps
    Replies: 1
    Last Post: 03-22-2014, 09:59 AM
  3. Galaxy Tab 2 10.1: Help with root
    By help me please help in forum Samsung Galaxy Tab 2 10.1
    Replies: 5
    Last Post: 03-22-2014, 09:16 AM
  4. Play Store will not open after factory reset
    By EviI in forum Google / Samsung Galaxy Nexus
    Replies: 0
    Last Post: 03-22-2014, 01:52 AM
  5. Replies: 0
    Last Post: 03-22-2014, 01:09 AM