1. LunaEros's Avatar
    Huawei Mediapad stock ICS 4.0.3
    Only real mod done Xposed Framework but no modules are active.

    Any 3rd party app I try that uses the Google maps for it's map function won't show any maps in it.
    Yet Google maps itself does. the Google is at version 6.6.
    I know there's a newer version but when I update to that, when I try to open Google maps it shows a screen
    that has a button "accept & continue". When I click it it shows a notification saying it can't connect to network yet everything else CAN connect to the network.

    I don't really care whether the google maps works or not but I need it to work for where I do use it in the 3rd party apps.

    Has anyone heard of this problem? Or has any kind of idea of what to do?
    03-26-2014 06:46 PM
  2. Golfdriver97's Avatar
    Have you emailed the developer? It may be an issue with the app accessing Google maps.

    From a Liquid Nexus 5
    03-27-2014 12:05 PM
  3. LunaEros's Avatar
    Thanks for replying.
    I'm 99% sure it's not the apps because every single app I try that uses Google's map api service has the same problem.
    They go to the map part of the app but none actually show a map. Just the Google shadow logo in the bottom left.
    Yet the Google map app itself works perfectly except for the fact that when I go into Play store it shows there's an upgrade from the v6.6 I have but when I try the upgrade and open it it gives a screen with 'accept & continue' button that when I try to select it I get a dialog that it can't connect to the network.
    So I uninstalled the upgrade and it works again. The Google app that is.
    03-27-2014 12:17 PM
  4. B. Diddy's Avatar
    Try going to Settings/Apps/All, select Maps, and Clear Cache & Data. Try this for both the preinstalled version and the update version.

    Posted via Android Central App
    03-27-2014 01:05 PM
  5. B. Diddy's Avatar
    No idea of this will help, but also consider clearing the cache and data for Google Play Services, then rebooting.

    Posted via Android Central App
    03-27-2014 01:07 PM
  6. LunaEros's Avatar
    That's something that didn't occur to me.
    Thanks. I will try that to see if it works and get back.
    03-27-2014 01:12 PM
  7. LunaEros's Avatar
    Well I tried those things....
    Same damn problem.

    I wonder if I find the google apps package that you install when you install a custom rom would overwrite any problem and fix it?
    I don't even know if that works on a stock rom.
    03-27-2014 01:36 PM
  8. B. Diddy's Avatar
    Is it mostly browsers where you're seeing this, or other apps like Yelp?

    If browsers, then how many different browsers have you tried?

    Posted via Android Central App
    03-27-2014 01:57 PM
  9. LunaEros's Avatar
    I don't have a problem with browsers.

    It's 3rd party apps that directly access the map api.
    Intellicast Weather app
    Cell Mapper app.
    Things like that.

    I did uninstall the T-Mobile installed Telenav app but I didn't think it would be a problem since it was 3rd party and the navigation function of Google Maps still works.
    03-27-2014 02:03 PM
  10. B. Diddy's Avatar
    Also low yield, but try resetting all app preferences/defaults.

    Posted via Android Central App
    03-27-2014 02:07 PM
  11. LunaEros's Avatar
    You mean go into each app's preference there's a problem with and reset to defaults?

    I never changed the default settings on those apps. Nor the main Maps app either.
    03-27-2014 02:13 PM
  12. B. Diddy's Avatar
    In the main Settings/Apps menu, if you tap the menu button, you should see an option to Reset App Preferences, which clears every app default. (It'll also enable any disabled app.). As I mentioned, it's low yield, but might still be worth trying.

    Posted via Android Central App
    03-27-2014 02:18 PM

Similar Threads

  1. Replies: 19
    Last Post: 07-22-2014, 07:25 PM
  2. HTC One (M8) is too tiny, any chance they'll come out with the One Max M8?
    By CarrierPigeon in forum Rumored Devices Lounge
    Replies: 4
    Last Post: 03-30-2014, 08:37 PM
  3. How to Stream: Google Drive Videos? > Chromecast
    By computerfreak123 in forum Google Chromecast
    Replies: 1
    Last Post: 03-30-2014, 02:31 AM
  4. Galaxy s4 loading os help
    By darkangel123elijah in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 03-26-2014, 05:11 PM
  5. Can't download and install anything from Google Play
    By Game Zone in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 03-26-2014, 04:46 PM