1. Leander Lottering's Avatar
    Hi all,
    I have a Samsung galaxy S3 which is about a year old. About 2 days go i tried updating my software to Kit.Kat. It said update is complete but it just needs to reboot so i said yes. Now when i switch my phone on it turns on and when it gets to the Samsung logo it just flashes and stays on the Samsung logo. I have tried connecting my phone to kies but i have had a problem with my phone connecting to the computer. I also don't want to restore to factory default because i don't want to loose all my photos.
    PLEASE HELP ASAP.
    Thank you
    Leander.
    05-07-2014 01:32 PM
  2. poemsme's Avatar
    I've never heard s3 get update for kitkat this quick. That's official update or not?
    U're phone rooted?

    Sent from my GT-I9300 using Tapatalk
    05-07-2014 02:24 PM
  3. Leander Lottering's Avatar
    No never rooted nothing. It said you need to update your phone to the latest software so i did,.........
    05-08-2014 12:28 PM

Similar Threads

  1. Does 4G LTE Symbol is shown in the device? Samsung Galaxy S5
    By pepejjla in forum Samsung Galaxy S5
    Replies: 16
    Last Post: 01-19-2015, 08:36 PM
  2. Gmail android problem
    By dougltc in forum Android Apps
    Replies: 2
    Last Post: 05-07-2014, 11:04 PM
  3. i717 Audio Problems! PLEASSSSE HELP
    By Sydney Hodge in forum Samsung Galaxy Note
    Replies: 4
    Last Post: 05-07-2014, 02:18 PM
  4. Problem accessing SD card memory and disappearing Apps
    By Chippy193 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 1
    Last Post: 05-07-2014, 01:38 PM
  5. As New Galaxy S4 I90505 says 'Custom'
    By Nigel Love in forum Samsung Galaxy S4
    Replies: 2
    Last Post: 05-07-2014, 12:50 PM
LINK TO POST COPIED TO CLIPBOARD