1. Richie Goldsworthy's Avatar
    I'm new here. If this thread is in the wrong forum, do forgive me.

    I have a Lenovo A1000L-F (the cheapy version, but it still has 16GB of internal storage) 7" tablet running Android 4.1.2 Jelly Bean, and just yesterday, I started experiencing the issue that I titled the thread off of.

    Yesterday, I decided to install two applications, Clumsy Ninja and Hungry Shark Evolution. But, both applications come up with the error after downloading them, "Couldn't install on USB storage or SD card.". I have never experienced this issue before, and even though it seems to be quite well-covered, I cannot find any solutions to my problem. I have tried just about everything under the sun and nothing has worked. Here are some things I tried:

    • Shutting down over night
    • Rebooting the device
    • Clearing data for the Google Playstore
    • Unmounted and remounted my SD card
    • Unmounted my SD card to attempt to install the applications
    • Removed the SD card completely
    • Change default installation locations
    • Rooting the device to find the "smdl2tmp1.asec" file in either of its known locations (I didn't find the file in either location. I could not find the file while browsing my tablet's storage on my computer either)
    • Resetting permissions
    • Installing via Google Play in the browser
    • Erasing and reformatting my Micro SD card, in Android, Windows and Mac OS X

    I have not done a factory reset. Based on other people who have tried it to solve the issue, it doesn't seem to have solved it for them. So, I'm skeptical about that too. Not only that, but I will lose everything, including its rooted status, which I don't want to have to do all over again. It was a pain to root my device.

    Some apps do install, but they are usually utilities. The rest I cannot get to install.

    Can someone please help me? This is extremely frustrating.
    Attached Thumbnails Couldn't install on USB storage or SD card-photo.jpg  
    05-25-2014 05:27 PM
  2. srkmagnus's Avatar
    It sounds like you are low on memory. Although you have 16 GB, there's only a certain amount dedicated to app data. Go into your memory from system settings and see what is available.

    Sent from my Nexus 5 using AC Forums mobile app
    05-25-2014 05:40 PM
  3. Richie Goldsworthy's Avatar
    Internal Storage (Partition 1): Total space is 3.00GB, 1.74GB is available.
    USB Storage (Partition 2): Total space is 10.58GB, 6.23GB is available.
    SD card: Total space is 0.93GB (1GB SD card), 0.93GB available.

    I don't think low memory seems to be the problem. I don't think the small SD card capacity is really the issue either, because I did try installing the applications without the SD card inserted.
    05-25-2014 05:44 PM
  4. Richie Goldsworthy's Avatar
    I tried getting the APK files and installing them directly…Still couldn't get them to install. What on Earth is this all about? The apps are compatible with my device, I know for a fact, otherwise it wouldn't let me install them to begin with.
    05-25-2014 09:03 PM
  5. Richie Goldsworthy's Avatar
    Okay, it seems that it is just those two applications, Clumsy Ninja and Hungry Shark Revolution that I cannot install. I did a factory reset (which still didn't solve my issue, by the way. My device is still rooted as well.) and all the other applications that I like on my tablet installed without issue. I'm installing Asphalt 8 right now, and I will see if it will install. As I said in my last post, I could not get the applications to install directly without the Play Store either.

    EDIT: Asphalt 8 installed and runs fine. It can't be an issue related to the games being 3D.
    05-26-2014 05:37 PM
  6. Dessie Dare's Avatar
    We got our kids some tablets last Christmas (Just so we could get our phones back!)
    Again nothing fancy, it's a Denver AC-70072K (Danish Brand) running Android 4.1.

    In general they have both worked great up to about 3 weeks ago, then one of them developed this problem when updating Apps that are already installed.

    Both kids have the same games installed and both are MineCraft mad. A couple of weeks ago, the younger one's Tablet auto-updated MineCraft Pocket Edition (Mojang) to version 9.0. The older one noticed that his was still on v8.1 and missing lots of new stuff. The peace that Minecraft once brought to the back seat of our car (long journeys only) is now gone.
    I have been trying to update Minecraft on his tablet ever since.
    I searched for the mysterious "smdl2tmp1.asec" file in all suspect locations. (Even mounted the tablet on my PC just in case.) Not a trace!
    I moved it from SD to Tablet storage and tried to update then. No cigar!
    He has tonnes of storage on his SD and Tablet. The App takes only 12MB and it's already installed!!
    Installing new apps works fine as does update of most others. (I have noticed 3-4 other apps that have the same error on update.)

    At my wit's end.
    07-31-2014 04:03 AM
  7. Sophia Brunt's Avatar
    Hi, I don't know if you managed to fix the problem or not, but, I too was having the same problem and googled and googled, tried everything from finding some tm1 (something) file, soft reset etc, with no luck.

    Anyway, long story short, I managed to get past the 'couldn't install on USB storage or SD card' by simply connecting my phone to the laptop via usb, turned on usb storage, opened up the web browser on the laptop, went to the google apps store (on the laptop) and thought oh what the heck I'll try it anyway... searched 8ball pool (instead of download) the button said install, a google apps box popped up with my mobile device info and said it was going to install on my device, I thought mmm ok. So i watched it download onto my phone, then start installing, THEN "Sucessfully Installed". Opened the app and sure enough Good to Go Whoop Some ****

    Hopefully it will work for you too.
    08-13-2014 04:02 AM
  8. Jack Liddelow's Avatar
    I have a similar problem on my ASUS MemoPad 7, but the two games in question are True Skate and Minecraft. I have Android 4.4.2 Kit Kat, it actually worked on my other two tablets, but not this one. My device isn't rooted and there's enough memory left in my storage. I'll post a picture on Google+ to show you what I mean.
    01-01-2015 12:14 AM
  9. Jessica Steele's Avatar
    This worked for me - thank you so much for posting this comment as I have been trying for over 2 weeks to install an app that just wouldn't work - hooked it up to computer and within seconds had my app installed. Thank you!
    01-18-2015 02:49 PM

Similar Threads

  1. Samsung Kies 3 installer
    By Chris8414 in forum AT&T Samsung Galaxy Note 3
    Replies: 8
    Last Post: 12-31-2014, 07:59 PM
  2. Nexus 5: No Applications Will Update On New Phone (FIXED)
    By DirkBelig in forum Google Nexus 5
    Replies: 1
    Last Post: 05-28-2014, 07:59 AM
  3. S5 Rebooting on Ap Install?
    By Effect One in forum Samsung Galaxy S5
    Replies: 4
    Last Post: 05-26-2014, 06:03 PM
  4. My opinion on the rumored Android Redesign
    By ajpri in forum General News & Discussion
    Replies: 5
    Last Post: 05-26-2014, 01:04 PM
  5. Question about 4K/UHD recording on KK
    By Relgoshan in forum Samsung Galaxy Note 3
    Replies: 1
    Last Post: 05-25-2014, 05:11 PM