1. Sarah Vanhousen's Avatar
    So my mother just gave this to me yesterday, it worked perfectly then it died from loss of charge. So we charged it and she erased the content and settings and we switched the Sd and memory card thing (by the sim card) I charged it at home and then pressed the power button, it started to load and then it came to the samsung logo screen where the logo spun once around then stopped loading. I've tried rebooting it by taking out the battery and the cards and pressing vol. +, home, and the power but it just did the same thing, it turned on and went to the logo which froze again. It does this over and over again. Please help, I need this phone to work asap.
    05-28-2014 09:08 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Try booting into Recovery and select Wipe Cache Partition, then Reboot System Now: http://forums.androidcentral.com/sam...2-s3-tab2.html
    Golfdriver97 likes this.
    05-28-2014 12:01 PM

Similar Threads

  1. Is it OK to charge the phone from 30%/50% to 100%?
    By Omer San Gabriel in forum General Android Device Chat
    Replies: 6
    Last Post: 03-09-2017, 01:22 AM
  2. Lots of data being used on my Verizon Droid DNA
    By GNX231 in forum Verizon Droid DNA
    Replies: 14
    Last Post: 06-01-2014, 08:55 AM
  3. Can't restore my.sidebar
    By crazycrew in forum Samsung Galaxy S4 Active
    Replies: 3
    Last Post: 06-01-2014, 05:48 AM
  4. Samsung galaxy s3 lte kitkat
    By NeonZX in forum Android 4.4 KitKat
    Replies: 0
    Last Post: 05-28-2014, 08:53 AM
  5. How to unlock call recorder on samsung galaxy s4?
    By Gerardram in forum Android 4.4 KitKat
    Replies: 1
    Last Post: 05-28-2014, 08:48 AM