1. Dangaard's Avatar
    I recently purchased a Belkin mini surge protector with 2 USB charging ports, each outputting 5V/500mA
    Mini Surge Protector with USB Charger

    However when I went to try charge my Sony Xperia TX (LT29i) using the USB ports, it doesn't detect that it's plugged in and doesn't charge. When my phone is turned off, it does however detect being plugged in and charges. Using an app called Battery Monitor, my phone seemed to show no difference in battery flow while turned on between being plugged into the USB port or not. Trying to charge an external battery from the same ports works fine.

    Normally I would presume it's because the current isn't strong enough, but AFAIK, computer USB 2.0 also outputs 5V/500mA and I regularly charge my phone from computer USB 2.0. Then I read a couple of mentions that Sony Xperia phones for a while made life difficult for no reason and wouldn't charge if there wasn't a data connection detected, and yet I also regularly charge my phone out of external batteries (2.1A/1A) as well as from a different Belkin surge protector with USB ports (also 2.1A/1A).

    Then I tried to charge it in the mini surge protector's USB ports while blocking the data transfer strips with a piece of paper as per USB Charge Cable Hack and after realizing that wouldn't change anything (I think), I tried plugging it into my computer's USB 2.0 ports using the same method. No charging and no connection detected, yet trying to charge an external battery with the same method resulted in success in both cases. I don't know enough about this sort of thing to know if actually shorting out the wires for data connection in the cable would produce different results, and I also don't have a soldering iron either.

    What gives? Is my phone only capable of charging over a 500mA source if there's a data connection? Am I just SOL here? Any thoughts would be greatly appreciated!

    As an aside, how does one find out if a particular device requires a certain amount of current to charge? I mean it's one thing for a device to charge extremely slowly without adequate ampage, but I have heard that some devices won't even bother charging at all without a certain amount.

    I'll also note that neither Sony nor Belkin customer support could come up with a solution for me and both essentially said they didn't know what was wrong, not that I expect great things out of customer support chats xP
    05-28-2014 06:18 PM

Similar Threads

  1. Data is on, but can't access the internet
    By ehendraw in forum Google Nexus 4
    Replies: 27
    Last Post: 03-08-2019, 09:00 AM
  2. Galaxy S4 will let me receive MMS texts but I can't send a text to anyone!! HELP
    By Traci Stiltner in forum Legacy Android & Other OS's
    Replies: 1
    Last Post: 07-23-2014, 10:55 AM
  3. Getting my free Xperia Z2
    By lazagna in forum Sony Xperia Z2
    Replies: 7
    Last Post: 05-30-2014, 10:35 AM
  4. Update all button doesn't really update all in play store
    By demontooth in forum Legacy Android & Other OS's
    Replies: 2
    Last Post: 05-29-2014, 08:07 AM
  5. Having Problems With My Chargers?
    By stepaul8 in forum General Help and How To
    Replies: 1
    Last Post: 05-28-2014, 10:05 PM