1. nurpinn's Avatar
    New to the forum. Greetings everyone.

    So I've now had this problem with 3 phones and 2 cars. When I sync my phonebook with my car's phonebook via bluetooth, I end up importing a ton of email only contacts (contacts with no phone numbers) to my car. As you can imagine, this makes a good percentage of my entries in my car's phonebook useless.

    Does anyone have a good way to avoid having to sync email only contacts? I've looked online and have not been able to find a post that addresses this. Thanks!

    Don't know that it matters but:

    Phone: ATT GS5
    Car: Audi S5
    06-09-2014 06:32 PM
  2. ShaggyKids's Avatar
    You might try setting your phone to display phone contacts only. It sounds like you may be displaying more than one group of contacts such as your Google contacts, your phone contacts and whatever else options they have in there.

    Go to contacts and then touch the left button on the bottom of your phone and you should get an option up that says "contacts to display." Choose Device.

    Notes from Deb's Note 3
    06-10-2014 03:46 AM
  3. pollensa1946's Avatar
    I think it may well depend on how the bluetooth s/w on your car works. I found that when I sync'd my new phone with my car that the car display showed a combination of those contacts on my gmail a/c (with updated info) AND old contacts on my sim (with old info). Result was duplicate entries. Only by clearing out my sim was this fixed. So the Display Phone Contacts only solution may well fail.
    06-10-2014 10:28 AM
  4. nurpinn's Avatar
    Yea, so it failed. I just tried it yesterday. To provide some more detail, what ended up happening was the navigation was asking permission to view my contacts and call logs. If I did not grant permission, incoming calls were showing up as phone numbers, and not names. If I grant permission, there were hundreds of blank contacts. Even if I displayed only contacts with phone numbers, this occurred. My makeshift solution so far has been to allow connection, then delete the phonebook on the navigation, and manually save individual contacts after I make or receive calls.

    Stinky workaround, but it's all I've got. I'm open to other suggestions though.
    06-13-2014 02:17 PM
  5. ShaggyKids's Avatar
    What I've done on occasion is to clear out all old stuff that I don't need anymore from all sources and then resync my phone. In other words log on to your Gmail account from your PC clear what you don't need. Plug your phone into your computer and go to your SD card and clear out there. Or if you sync with Outlook you can do it in the Outlook email.

    Notes from Deb's Note 3
    06-13-2014 10:39 PM
  6. pollensa1946's Avatar
    I share nurpinn's problem and that is that my gmail/phone Contacts dbase is my one, central record of all my contacts, whether phone, email, home/business address, related notes. Gmail Contacts is in fact perfect for this. So "clearing out" is not an option. Many of those contacts I don't have a phone number for so there are occasions when I would like to display only those that I do have numbers for, in the car being an example. So your proposed solution simply does not fly. The problem is essentially that the typical car bluetooth s/w is not written to deal with this situation. What is needed is an Android-based car OS.
    06-14-2014 12:23 AM
  7. ShaggyKids's Avatar
    It works for my needs. I don't want my contacts anywhere near Google. Sorry it won't work for yours.

    Notes from Deb's 2014 Note 10.1
    06-14-2014 01:18 PM
  8. pollensa1946's Avatar
    Interesting development. I checked the s/w level of my BMW telephone interface, discovered it was downlevel, updated it and now only those contacts with telephones are displayed. Who needs Android on a car.
    ...and I just got a new DECT landline phone for my home and it discriminates to phone contacts only. Things are looking up in the bluetooth sphere.
    06-15-2014 06:24 AM
  9. KelseyRo4's Avatar
    On the phone to remove contacts:

    Settings > Accounts > Google > select account > Disable contacts sync.
    This will keep them off after deletion. Then...
    Settings > Apps > Contacts storage > Force stop > Clear cache > Clear data.
    You will, of course, erase all contacts on the phone.

    This worked for me
    12-21-2015 02:28 PM

Similar Threads

  1. Looking for my 'dream' device
    By NavadeHi in forum Android Concepts & Dream Devices
    Replies: 6
    Last Post: 07-10-2014, 09:37 AM
  2. Cases compatible with wireless charging back
    By ebab72 in forum Samsung Galaxy S5
    Replies: 5
    Last Post: 06-11-2014, 05:15 AM
  3. Phone got wet, need advice on my best bet from here.
    By tannerrblake in forum Samsung Galaxy Note 3
    Replies: 5
    Last Post: 06-10-2014, 01:40 PM
  4. How to Record Telephone Conversation
    By mickeyboat in forum Samsung Galaxy Note 3
    Replies: 5
    Last Post: 06-10-2014, 02:17 AM
  5. How do I get the notification to vibrate
    By Help_Me_Harry in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 06-09-2014, 07:35 PM