1. Acrazydeveloper's Avatar
    Yesterday I purchased Datawind UbiSlate 3G7 Tablet. Here is the link to the manufature's website Ubislate 3G7 Phablet, Tablet With Calling, 3G . I have absolutely no idea about android. I am not at all familiar with the technical jargon. The thing is it did not had Google Play store installed so I went to the play store's website and tried to install it. After clicking the install button it said that this will take some time and after some time "installed" appeared on the play store but no icon or shortcut appeared on the home screen.
    By careful observation I noticed that in the play store the device was listed as Samsung something... Then I recalled that I had used the same account to make some install in my in laws phone.I went to the play store settings and then I deleted that device from my account.Now when I try to visit play store by my tablet it says that "No devices detected".I read in some other forum and tried to install play store through apk file(I have no idea what that is). Installation was successful and an icon appeared on the home screen. But when I click on it play store appears to open but I am redirected to homescreen. I have absolutely no idea what's going on. Can anyone help me.Any help would be appreciated.

    Pardon my english as its not my first language.

    P.S. My tablet does have a Slideme Marketplace. Does that mean I cannot use the google play store.
    06-24-2014 03:23 AM
  2. Acrazydeveloper's Avatar
    Anyone Please....
    06-24-2014 04:35 AM
  3. Golfdriver97's Avatar
    You not only need Play store but Google Play Services. What happened was that OEM did not want to pay licensing for the Google Apps which includes the Store and Services.
    06-25-2014 09:22 AM
  4. raptir's Avatar
    I honestly didn't think you could install the play store from the web. Are you sure it was the real Google site and not a site pretending to be the play store? The real Google site is play.google.com. I'm just worried you may have ended up with something malicious installed.

    Either way, as above, you need a lot more than just the Play Store. You would need to figure out how to root your tablet. It doesn't look like there is a "published" way to do that so you'd be more or less on your own. Once rooted, you need to get the Google Play Services framework installed. If you really want to pursue this, you might want to start looking at information on how they did it with the Kindle Fire.
    06-25-2014 09:48 AM
  5. Acrazydeveloper's Avatar
    Thanks raptir. I am sure I used the Google Play Store website. I tries installing Google Play Services but it error "the play services cannot be started". I will look into the kindle fire thing.
    06-26-2014 08:46 AM
  6. Rukbat's Avatar
    Look into the Amazon App Store. They have an app you can download that's about the same as the Play Store app, and they have about the same apps and games that the Play Store has (and for the same prices for the non-free ones). You can also install an app or game from the website - you don't actually need the app. (That holds true for the Play store too, but it has to recognize your device and, since you're missing so many Google apps, it probably won't.)
    06-26-2014 10:48 PM

Similar Threads

  1. New to Android, I love this tablet
    By bluedisk in forum LG G Pad 8.3
    Replies: 3
    Last Post: 06-28-2014, 08:50 PM
  2. Do Android app updates decrease internal storage space?
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 06-24-2014, 08:25 AM
  3. Help: How to add ttf fonts in samsung tab 3
    By janiit89 in forum Android 4.4 KitKat
    Replies: 0
    Last Post: 06-24-2014, 01:50 AM
  4. IMovie type app for Android / Samsung ????????
    By Davyo in forum Tablet Apps
    Replies: 0
    Last Post: 06-24-2014, 01:29 AM