1. snowdog09's Avatar
    I dropped my Nexus 5 on tile. It is running Kit Kat never been rooted. I picked it up and tried to unlock it and wake the device. It did nothing. I plugged it in to the charger and it showed the black and white charging symbol. I then pressed the power button and it turned on. It is now on and the power button and volume buttons don't work. I unplugged it and now the charging symbol went away. I plugged it back in and won't come back. The notification bar says charging 51% even when unplugged. RIght now it is plugged into a wall charger and I have WiFi on while I back up stuff. I plugged it into my copmuter and it shows nothing. Please Help!!!!! I don't know if it is dying in my hands or if it is actually charging or what. I put it on the wireless charger and it does the same thing.
    10-16-2014 04:05 PM
  2. Golfdriver97's Avatar
    It is possible the device was damaged internally when it fell. Do you have any local repair shops that can look at it?

    Sent from an AOSP M8
    10-16-2014 04:35 PM
  3. snowdog09's Avatar
    It is possible the device was damaged internally when it fell. Do you have any local repair shops that can look at it?

    Sent from an AOSP M8
    Yes. I just did a hard reset by holding down both volume and power and it restarted. Buttons still don't work though. It is showing it's charging and it's going up though.
    10-16-2014 04:57 PM
  4. snowdog09's Avatar
    I just booted it into safe mode and the buttons still don't work it charges now too. So not that urgent anymore. But if you can help it would be greatly appreciated.
    10-16-2014 05:17 PM
  5. Rukbat's Avatar
    Something inside the phone broke. Considering all the problems, it's probably the motherboard, at least. It has to go to a repair shop, at least for an estimate. (The repair price may well be around the price of a new one.)
    10-16-2014 05:42 PM
  6. snowdog09's Avatar
    Something inside the phone broke. Considering all the problems, it's probably the motherboard, at least. It has to go to a repair shop, at least for an estimate. (The repair price may well be around the price of a new one.)
    That's what I thought, but now I'm not sure. I did a factory reset and the buttons still don't work but everything else is normal. But it I hold down the power button it will turn off. And if I run the boot loader the volume keys will function like normal. This makes me think it's a software problem.
    10-16-2014 10:05 PM
  7. snowdog09's Avatar
    This is no longer urgent, but if you can still help that would be awesome. Thanks for you help.
    10-16-2014 10:05 PM
  8. Golfdriver97's Avatar
    I am actually lost on what to suggest next. I am reasonably certain this is a hardware issue.
    10-16-2014 10:41 PM
  9. snowdog09's Avatar
    It just seems weird though that the buttons work, but only for certain functions.
    10-17-2014 12:55 AM
  10. Rukbat's Avatar
    It's a Nexus 5. Go to a Nexus 5 forum - here or on XDA - and ask where you can find a stock ROM and what program you use to flash it. I'm sure there are plenty of people with Nexus 5s who have done it many times.
    10-19-2014 01:02 AM

Similar Threads

  1. Didn't know the N5 was capable of battery life like this
    By mclasser in forum Google Nexus 5
    Replies: 14
    Last Post: 10-20-2014, 11:05 AM
  2. Replies: 4
    Last Post: 10-17-2014, 04:17 AM
  3. pick up tmobile note 4 tomorrow in store?
    By sdanaher in forum Samsung Galaxy Note 4
    Replies: 3
    Last Post: 10-16-2014, 06:14 PM
  4. Replies: 0
    Last Post: 10-16-2014, 03:45 PM
  5. Is there any way to download pre-made custom vibrations
    By Kevin Bader in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 10-16-2014, 03:34 PM
LINK TO POST COPIED TO CLIPBOARD