1. Khalid Al-Sharif's Avatar
    I had my Samsung for almost 2 years now. The battery was swollen for a month, I got my new battery earlier today. Worked perfectly fine, until it reached about 40% and then it showed the startup screen for the Samsung. I tried removing the battery and putting it back in, as soon as I put the battery in, the boot screen shows up then goes, and it loops. I tried putting it to safe mode (Home + Lock + Volume Up) but it won't work, keeps booting. It won't work at all. Please help!
    10-19-2014 04:31 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! A couple of things to try:

    1. If you have an SD card, pull the battery, then remove the SD card while the phone is off. Now try powering up again. A corrupt card can cause problems sometimes.

    2. If that doesn't work, try booting into Recovery Mode and wiping the cache partition: Reset: Samsung Galaxy S 4 | T-Mobile Support
    10-19-2014 09:41 PM
  3. Khalid Al-Sharif's Avatar
    Thanks, for the first point, removing the SD didn't help.
    for the second one, whatever I do on the phone, the logo keeps coming and going.

    I got it to work yesterday after posting this. But it went back to the same process. Not sure what to do now.
    10-20-2014 01:01 PM
  4. B. Diddy's Avatar
    Is this replacement battery also swollen now?
    10-20-2014 02:23 PM
  5. Khalid Al-Sharif's Avatar
    10-20-2014 02:33 PM
  6. B. Diddy's Avatar
    Are you able to get to the bootloader or the Recovery Menu at all? You might consider reflashing the stock ROM: http://forums.androidcentral.com/amb...-via-odin.html
    10-20-2014 02:37 PM
  7. Khalid Al-Sharif's Avatar
    Does this work with a Mac?
    10-20-2014 02:38 PM
  8. Khalid Al-Sharif's Avatar
    And when it says "A copy of your stock ROM in question." What's that?
    10-20-2014 02:40 PM
  9. B. Diddy's Avatar
    I don't know about the Mac. You can probably find the stock ROM for your device here: Firmwares | SamMobile. Make sure you find the one for your specific model number.
    10-20-2014 04:04 PM
  10. Rukbat's Avatar
    1) For MacOS you use Heimdal, not Odin. (Odin has a much simpler interface, so I'd suggest that you find someone with a Windows computer who's willing to install Odin and let you flash the ROM there.)

    And when it says "A copy of your stock ROM in question." What's that?
    2) SamMobile uses the model number (i9500, or whatever yours is), not the model name (s4). And you'll have to create a free account to download the file. (Make sure it's not only for your model number, but also for your country/carrier.)

    If the ROM has an orange box at the right end, you can use Kies to flash it. You can get Kies for MacOS at https://forums.androidcentral.com/e?...token=8F2E6V7B (scroll down to the bottom). Then just use the Update function in Kies to update the phone with the file you downloaded.
    10-20-2014 04:09 PM

Similar Threads

  1. Galaxy s4 won't turn on
    By Cam275 in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 10-19-2014, 09:54 PM
  2. Replies: 0
    Last Post: 10-19-2014, 02:57 PM
  3. Replies: 2
    Last Post: 10-19-2014, 12:54 PM
  4. Replies: 1
    Last Post: 10-19-2014, 12:38 PM
  5. Why is my lock screen activating randomly?
    By Irisse Ortiz in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 10-19-2014, 12:09 PM
LINK TO POST COPIED TO CLIPBOARD