1. original_cheezmonkey's Avatar
    My son's tablet will no longer start up. It is a generic Chinese tablet, but I have the box, manual etc to provide what limited info there is, if needed.

    The box has "Nebula 1701" on it and has a picture of the Starship Enterprise .

    Some of the Spec:

    7 Inch
    800x480 display
    Dual Core 1.6Ghz
    512MB DDR3
    Mail-400 GPU

    The problem is when the tablet is turned on, it shows the Nebula splash screen as always but instead of proceeding to the Android logo and then the desktop, it just shows the Nebula logo forever. We left it to fully discharge on that screen and it never proceeded further. It will also not turn off in this state, if I hold the power button for about 10 seconds the screen goes off, but when I release it, it comes back on immediately, back at the Nebula logo.

    If I plug it into the mains, holding the power button will turn it off and I can see the charging icon as normal, but if you turn it on, again, it will hang.

    The machine only has 3 buttons - standby, vol + and vol - and I have tried starting it with every permutation possible and nothing is any different. I am officially out of ideas

    Thanks.
    10-25-2014 01:03 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! I'm afraid you may simply be out of luck. Budget off-brand devices like these are notorious for defective hardware or firmware, as well as minimal to no support. You've already tried what I would have suggested--i.e., trying to boot into Recovery Mode using some combination of the various buttons.
    10-26-2014 01:52 AM
  3. original_cheezmonkey's Avatar
    Thanks for the reply B. Diddy, I Was afraid someone was going to say that. There is, after all, only so much one can do with three buttons

    I think it's time we bought him a reputable brand one. Have a great day.
    10-26-2014 06:49 AM
  4. B. Diddy's Avatar
    The only other thing I can think of is to remove the SD card and reboot, in case the SD is corrupt and really causing problems.
    10-26-2014 11:38 AM
  5. chris chesham's Avatar
    On the top of the tablet there should be a tiny hole .while its powered up on battery.that is NOT plugged in the mains
    Push in a sewing needle point first ,you should feel a click.this resets things without any loss of things but clears down things.
    01-14-2015 06:28 AM

Similar Threads

  1. PDF annotation on Shield Tablet?
    By chef91 in forum SHIELD Tablet
    Replies: 9
    Last Post: 05-07-2015, 05:56 PM
  2. Navigation commands no longer working in 4.4.4
    By FBA in forum Samsung Galaxy Note 4
    Replies: 4
    Last Post: 10-25-2014, 08:31 AM
  3. Replies: 1
    Last Post: 10-25-2014, 12:54 AM
  4. I have no idea how to fix my black/ really dull screen..help?!
    By Mariah Hensley in forum Ask a Question
    Replies: 1
    Last Post: 10-24-2014, 08:52 PM
  5. How do I root an EVGA Tegra Note 7 tablet?
    By bajatrvlr in forum Ask a Question
    Replies: 0
    Last Post: 10-24-2014, 05:15 PM
LINK TO POST COPIED TO CLIPBOARD