1. Guzi's Avatar
    Hello everybody. Today I tried to flash the new Android 5.0 L update. I backed up all my data and did it. After booting, I tried restoring my data using MobileGO and this message popped up:
    Can't restore my Nexus 5 using MobileGO-aec4ceb4fb.png
    After closing the message, the program crashes.
    I don't know what to do! If I can't get my data back, I'm done :/
    Thanks for reading,
    Guzi.
    11-20-2014 08:22 AM
  2. srkmagnus's Avatar
    It's probably because the software can't restore data from one version of Android to the next. What data are you trying to restore?
    11-22-2014 10:39 PM

Similar Threads

  1. My LG G3 Brick
    By j_grouchy in forum LG G3
    Replies: 13
    Last Post: 12-01-2017, 08:07 AM
  2. Best Back-up solution for my Note 4
    By srechatt in forum Samsung Galaxy Note 4
    Replies: 3
    Last Post: 08-12-2015, 12:04 AM
  3. My take (review) of the Fire TV stick
    By drhere in forum Amazon Fire TV
    Replies: 11
    Last Post: 02-22-2015, 11:14 AM
  4. Gear S uninstalling apps on my phone? (iHeartRadio)
    By gearshead in forum Samsung Gear S
    Replies: 12
    Last Post: 01-13-2015, 08:17 PM
  5. Will my data be lost after the Lollipop OTA update is done on my Nexus 5?
    By Alexandru-Beniamin Ciuclea in forum Ask a Question
    Replies: 2
    Last Post: 11-20-2014, 07:43 AM
LINK TO POST COPIED TO CLIPBOARD