1. Skivey's Avatar
    So I se its a common problem on the N4 for the soft keys to stop working, but a lot of the posts say its a hardware failure...

    This cant be true, because the unlock 'padlock' is situated in the same area of the screen where the soft keys are, and this works fine..

    My phone isnt rooted, never has been - and I dont seem to be able to work out what third party apps I need to install to get at least a back button.. im having to reboot my phone all the time.

    Can anyone help me untill we get a fix?

    cheers

    Matt
    12-03-2014 05:13 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Are you saying that your soft keys are visible but don't respond, or that they aren't even there?
    12-04-2014 02:06 AM
  3. Skivey's Avatar
    Hi thanks,

    Yes they are visible, but they dont work. However when the phone is locked the unlock is in teh same part of the screen as the 3 soft keys.. and that button works.

    Its all very bizarre, I have managed to install an appthat allows me to use a sidebar of the buttons but that part of the screen seems to be dead when it is active, but when its locked it works... It since I updated to lollypop.

    Matt
    12-04-2014 07:13 AM
  4. B. Diddy's Avatar
    Try wiping the system cache partition: https://support.t-mobile.com/docs/DOC-5994
    12-04-2014 11:06 AM
  5. Endika's Avatar
    Hi,

    I have the same problem with mi N4 since yesterday, but in my case I updated to Lollipop 10 days ago.

    The soft keys suddenly stopped working. I'm not sure if it could be due to an app's auto-update, because I didn't do anything with the phone, I unlocked the phone to check the emails and the soft keys did not respond anymore.

    Anyway, I have tried to restart in secure mode and wipe the system cache partition, but the problem persists. What can I try next? maybe a Master reset? I don't want to lose the data and have to reconfigure the phone, but I will be happy to do it if I fix it

    Kind regards
    12-05-2014 01:59 AM
  6. B. Diddy's Avatar
    Welcome to Android Central! When you say secure mode, do you mean Safe Mode? https://support.google.com/nexus/answer/2852139?hl=en
    12-05-2014 03:31 AM
  7. Endika's Avatar
    Yes, sorry, I mean in Safe Mode.

    I have restarted the phone in Safe Mode and I have stopped as much services as I could but the problem persist. Then I have seen your post and I have tried to wipe the system cache partition, but it hasn't worked.

    Please, any advise will be much appreciated

    Regards

    Endika
    12-05-2014 07:58 AM
  8. Skivey's Avatar
    I tried everything, got annoyed so called google play and they offered me a replacement.... 8 months past warrantee...

    I think they know its a problem, and same as you it was after I installed lollypop.

    Matt
    12-12-2014 05:58 AM
  9. Endika's Avatar
    I did the same.

    The phone was still in warranty and Google replaced it without problems.

    Now I have Kit Kat (v4.4.4) and I don't know if update it or wait to a new release. The 5.0.1 should arrive in a few days.
    12-18-2014 03:03 PM

Similar Threads

  1. HTC One (M8): Mic on Snapchat Live Chat not working...
    By Trevor Laky in forum HTC One M8
    Replies: 9
    Last Post: 02-09-2015, 11:39 PM
  2. Here App not working
    By Primetimeplaya in forum Samsung Gear S
    Replies: 13
    Last Post: 12-31-2014, 08:20 PM
  3. is material design going to matter for most people?
    By RavenSword in forum General News & Discussion
    Replies: 1
    Last Post: 12-03-2014, 03:56 PM
  4. Why isn't my internal memory mounting?
    By ngokulan86 in forum Ask a Question
    Replies: 2
    Last Post: 12-03-2014, 08:34 AM
  5. What is the best free music app with album art?
    By Sammuel1973 in forum Samsung Galaxy Note 4
    Replies: 1
    Last Post: 12-02-2014, 11:00 PM
LINK TO POST COPIED TO CLIPBOARD