1. Missy103's Avatar
    I have a Huawei Ascend Y320-U10 and its been in a boot loop for a while now. Its already happened once before and i fixed it by wiping the cache or something along those lines. I tried the same thing but it was still in a boot loop so then i tried resetting it and its still not fixed! This is so frustrating and would really like a answer, all help is appreciated
    12-09-2014 01:20 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Can you try a new or different battery?
    12-10-2014 02:02 AM
  3. Missy103's Avatar
    no i only have one and cant buy one right now
    12-10-2014 09:12 PM
  4. B. Diddy's Avatar
    When you say boot loop, do you mean that the phone tries to boot up, gets as far as the logo screen, then shuts off again? That could very well be a battery issue, so trying a new battery is usually one of the first things to do.

    A quick way to confirm a failing battery is to remove it, place it on a table, and try to spin it. If it spins freely, it's bulging in the middle, which is a bad sign. But even if it doesn't spin, it could still be a battery issue--the spinning only confirms a problem, it doesn't rule it out.
    12-10-2014 09:46 PM
  5. Missy103's Avatar
    yeah i ment it does boot up but gets stuck on the logo screen, it can stay like that for hours. it doesnt shut off though, only if the battery power runs out.
    12-13-2014 10:16 PM
  6. Golfdriver97's Avatar
    You can try a reset in recovery.



    The steps don't start until about 25 seconds in the video.
    12-13-2014 10:42 PM
  7. Missy103's Avatar
    I know, i have tried this but it didnt help
    12-13-2014 11:50 PM
  8. Rukbat's Avatar
    Reflashing the ROM would probably fix it (unless there's some hardware gone bad). See if your carrier can/will do that for you. (You've already lost all your apps and data, so I hope you kept the phone pretty well backed up if there was anything important on it.)
    12-14-2014 11:59 PM

Similar Threads

  1. How can I downgrade my OS?
    By LuminaryLion in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 2
    Last Post: 12-15-2014, 12:03 AM
  2. RECOVERY! help help help
    By jaycuppp in forum HTC One M8 Rooting, ROMs, & Hacks
    Replies: 3
    Last Post: 12-11-2014, 06:21 PM
  3. GPS comes on now on phone calls?
    By binxiboo in forum AT&T
    Replies: 4
    Last Post: 12-10-2014, 06:38 AM
  4. Android Lollipop WinKey stopped working in my apps
    By atomiwins in forum Android 5.0 Lollipop
    Replies: 2
    Last Post: 12-09-2014, 08:21 PM
  5. Google play store can't reach google.
    By Zath Mendoza in forum Google Play Store
    Replies: 1
    Last Post: 12-08-2014, 10:31 PM
LINK TO POST COPIED TO CLIPBOARD