1. Mark Anderton1's Avatar
    Calling all Google Now experts, I request your assistance.

    On my UK EE HTC M8, I sometimes (usually whilst driving) use

    "OK Google" - "Send a text to my wife's mobile"

    It asks "What's the message?"

    I dictate it, and she says "Do you want to send this?"

    I say "yes", or "send" and I get the message on-screen that the message was sent.

    So far, so good. Except it's not. Because they never send, are never received, and never show up anywhere in either the built-in HTC messages app or Hangouts. At the moment my default SMS app is Hangouts, but I'm happy with either.

    I've tried going into the Google Search app settings and clearing defaults, but it made no difference. I've googled the issue, phrasing it as many ways as I can think of, and all I find are other people, in differing countries, with different hardware and software, having the same issue.

    Please help, I've bought an LG G Watch R, and hope to be able to dictate texts from it, but if this isn't resolved by the time I take receipt of the watch, I'll be missing functionality, and that makes me a SAAAAAADDD PAAAANDA.

    Coincidentally, the same function works fine for sending emails to people.
    12-13-2014 05:52 PM
  2. Rukbat's Avatar
    I've tried going into the Google Search app settings and clearing defaults
    That just makes Google Now not the default search app.

    Try clearing cache and data from Google Now. That seems to have helped with some problems (and there are tons of different ones, almost as if each copy picks a problem from a hat at random).
    Mark Anderton1 likes this.
    12-13-2014 06:11 PM
  3. Mark Anderton1's Avatar
    Thanks for your advice. I tried doing that, but no use. Still the same issue. At times like this I wish that Google had the equivalent of "Apple Stores" where I could take my phone for a Google Genius to have a look at it.

    I'm still at square 1, unfortunately!
    12-14-2014 09:29 AM
  4. Golfdriver97's Avatar
    Have you tried using Google's text app to see if that works?
    12-14-2014 09:56 AM
  5. NSLondon's Avatar
    I have exactly the same problem.
    I think this is a recurring problem, I have found this discussion on the google product website and no one gave a solution: Using an Android phone - Nexus 5 (4.4.4 kernel version 3.4.0-gd59db4e...), on UK Network T-Mobile, attempting to send a text message to a stored contact whose number is stored in the format +447801....... etc..

    Method - OK Google from home screen, send a text to name "I will be late home". This works and google now asks "do you want to send". I respond yes and it appears the text is sent. However, the next day I get a message from NetworkMSG which reads "Yesterday you sent a message to an invalid number. UK Mobile numbers start with 07 or +447. Numbers starting with 447 without the leading + are invalid.".

    The conclusion is that Android (or the part of it that works with voice commands) is ommitting the + when trying to send the message. If I use "OK Google" and call name (the same contact) this works correctly.
    Is this bug due to be fixed?

    Can anyone help please?
    12-15-2014 12:26 PM

Similar Threads

  1. Replies: 4
    Last Post: 03-13-2015, 04:17 PM
  2. Is it possible to make the lock screen weather widget transparent?
    By eobet in forum Samsung Galaxy Note Pro 12.2
    Replies: 1
    Last Post: 01-03-2015, 03:54 PM
  3. Replies: 1
    Last Post: 12-14-2014, 01:28 AM
  4. Replies: 1
    Last Post: 12-14-2014, 01:25 AM
  5. Why can't I screen mirror to Miracast anymore?
    By rlakritz in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 12-13-2014, 05:14 PM
LINK TO POST COPIED TO CLIPBOARD