1. Nick_593's Avatar
    Hi I have an old HTC Bravo. When trying to download apps from play store I get a message saying "Your device isn't compatible with this version".

    The phone wifi doesn't work when connecting to a network outside of the house. For example, using GPS for maps/ navigation and browsing, despite being connected to the mobile network.

    The phone was previously connected to Orange mobile. However the phone has been unlocked and is now running on 'Three mobile'. Phone call and texts work fine with the phone, however there are problems with using the internet/ GPS, etc.

    Can anyine help? Is there any way to upgrade the phone/ phone software or anything else?


    Thanks
    12-18-2014 02:46 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! If you have an older phone, many newer apps won't be compatible for various reasons, like hardware and Android version.

    For mobile data, check with Three Mobile to see if your APN settings are correct.
    12-18-2014 09:17 PM

Similar Threads

  1. Replies: 17
    Last Post: 12-29-2014, 05:25 PM
  2. Why can't I talk or hear when I make or receive a call after 5.0?
    By Arnon Klineman in forum Android 5.0 Lollipop
    Replies: 1
    Last Post: 12-19-2014, 01:25 AM
  3. Replies: 3
    Last Post: 12-18-2014, 01:21 PM
  4. firmware upgrade prompt - but my S4 mini came with 4.4.2
    By tripton in forum Samsung Galaxy S4 Mini
    Replies: 1
    Last Post: 12-18-2014, 05:56 AM
LINK TO POST COPIED TO CLIPBOARD