1. midnightmotorsport's Avatar
    Just got a Galaxy Avant (on T-Mobile network). When I am on the phone with somebody and a second call comes in, it rings at full volume and automatically places the first call on hold (or maybe even hangs up on them?), just gives me answer/reject options for the second call. Since this is my work phone, I am often juggling calls, and this automatic drop of my current phone call is REALLY annoying. Anybody experience anything similar? Any advice? My old Samsung Exhibit (yeah, I know) would just give me a gentle beep and the option to pick up the new call, but none of this loud-ring-and-auto-disconnect business.

    I have already made sure that call waiting is enabled and auto answer is disabled. This happens when the phone is against my ear, or on speaker on my desk, doesn't matter.

    I'd still like to get the notification of the new call and the option to answer, I just don't want the phone to automatically put the first call on hold with no warning. Also, that ringer in my ear at full volume when I'm mid-phone-call is really terrible.
    01-21-2015 07:56 PM
  2. srkmagnus's Avatar
    Just got a Galaxy Avant (on T-Mobile network). When I am on the phone with somebody and a second call comes in, it rings at full volume and automatically places the first call on hold (or maybe even hangs up on them?), just gives me answer/reject options for the second call. Since this is my work phone, I am often juggling calls, and this automatic drop of my current phone call is REALLY annoying. Anybody experience anything similar? Any advice? My old Samsung Exhibit (yeah, I know) would just give me a gentle beep and the option to pick up the new call, but none of this loud-ring-and-auto-disconnect business.

    I have already made sure that call waiting is enabled and auto answer is disabled. This happens when the phone is against my ear, or on speaker on my desk, doesn't matter.

    I'd still like to get the notification of the new call and the option to answer, I just don't want the phone to automatically put the first call on hold with no warning. Also, that ringer in my ear at full volume when I'm mid-phone-call is really terrible.
    I don't know why it would be doing this. However, I suggest going into the dialer app (phone icon) settings to see if there's anything in there that allows you to control the settings for incoming calls.
    01-22-2015 09:35 AM
  3. midnightmotorsport's Avatar
    Yeah, have tried the dialer settings, everything is "correct" for normal call waiting usage, have tried a million variations with no change... Was hoping that somebody had a similar issue with some resolution. Thanks for the input though. I'll update if I find some good resolution.
    01-24-2015 12:51 PM

Similar Threads

  1. Replies: 1
    Last Post: 01-22-2015, 10:36 AM
  2. How do I stop Talkback on my Samsung Galaxy Tab3 8 inch?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-22-2015, 09:34 AM
  3. Replies: 1
    Last Post: 01-22-2015, 09:32 AM
  4. Why is my Moto X stuck in reboot cycle after Lollipop update?
    By AC Question in forum Ask a Question
    Replies: 5
    Last Post: 01-21-2015, 08:18 PM
  5. How do I unstick my power button on my Samsung Galaxy S4?
    By SMouck in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 01-21-2015, 07:39 PM
LINK TO POST COPIED TO CLIPBOARD