1. molanic's Avatar
    I have a Hisense Sero 7 Pro tablet that supposedly has usb otg enabled by default. I want to be able to connect my full sized keyboard or mouse occasionally and possibly a Logitech k400 wireless keyboard in the future. I bought this usb otg adapter on Amazon for $4 (StarTech.com Micro USB OTG to USB Adapter, straight adapter with no cable)...sorry can't post links yet apparently. Payed a little more to get a really well reviewed one that I didn't have to wait to ship from China.


    I plugged in the keyboard (100mA 5v) and it didn't work, wasn't even getting power (no light on numlock). I tried it again and the tablet rebooted. Tried it with a mouse (100mA 5v), no go. One time I did get a flicker of light on the keyboard and then tablet rebooted. I tried it on another Hisense tablet, another brand tablet, a couple of phones and got nothing.

    I can use a regular micro usb cable to connect the tablet to the computer and charger and they both work so I don't think the tablet port is bad. Did I just get a bad adapter or am I doing something wrong? I can think of no other way to test it. I also tried testing the adapter with a charging cable, but don't know if that would work even if the adapter was functioning.

    If it is broken I will just exchange it , but don't want to be the boob who claims something doesn't work just because they don't know what they're doing!
    03-17-2015 11:14 AM
  2. SpookDroid's Avatar
    Only way to tell would be to try out the cable with another device that supports OTG. There really shouldn't be anything more to it than plugging in a keyboard or mouse and have it work if your device does support OTG. You could try testing a USB memory stick and see if that one works (not Hard Drives, unless it has external power source).
    03-17-2015 11:32 AM
  3. donald_s's Avatar
    In my experience, USB cables and devices can be funny. Some work with some devices some work with others. The problem comes from the fact that some cables are charging and data, but others are just charging. The pin configurations are different. The tablet may either not be able to use the USB as OTG, or it may be that it is seeing your cable as a charging cable, not a data cable. I would say, if you can make sure the adapter cable can deliver power to the tablet. If it cannot deliver power or data, then it doesn't work with your tablet or is defective. If that works, take the adapter and your mouse to a Best Buy store (if you have one nearby) and see if one of the Samsung tablets works with the mouse. They are almost all OTG. If that doesn't work, you have a charging cable adapter, no matter what the nice reviews said.
    03-18-2015 09:10 PM
  4. Rukbat's Avatar
    OTG cables aren't charging cables. (If that's a female USB to male microUSB cable without the OTG resistor, it's plain false advertising, and the company is hurting itself for a 5 cent profit - which is unlikely.)

    The mouse and keyboard may draw enough current, or the tablet may supply little enough current, that it won''t work without a 3 port OTG cable - the extra port supplies power to the USB device. (There's one on Amazon for about $7 - I can't tell you how well it works, because mine's scheduled to arrive on Tuesday. But I've never found sn OTG cable - even the $2 ones - that didn't work.)
    03-19-2015 10:08 PM
  5. molanic's Avatar
    Thanks everybody. Sorry I didn't respond sooner... I am new here and just assumed I would get e-mail notifications of replies but I didn't. I ended up just asking for an exchange from Amazon. I got the new one two days later and it works. So I guess I just got a bad one after all. Now at least I know how it is supposed to work. A thumb drive I plugged in did light up but did not recognize it. From my understanding I need to get the Nexus Media Importer app if I want to do usb otg with data storage devices and this tablet. For now I'm just using it for a keyboard and mouse though. From what Rukbat said this adapter should not work for charging the tablet at all either if I am understanding correctly. I don't need to do that, but it is good to know if that is not a viable way of testing for a bad adapter.
    03-20-2015 11:57 AM

Similar Threads

  1. Why isn't my batter charging on my Galaxy Grand Neo?
    By Rabia Ejaz in forum Ask a Question
    Replies: 10
    Last Post: 03-23-2015, 11:18 PM
  2. I can not install facebook on my huawei Y5300?
    By NDR01 in forum Android Apps
    Replies: 2
    Last Post: 03-19-2015, 01:02 PM
  3. Wakelock apps for non rooted devices?
    By ianhanson85 in forum Google Nexus 5
    Replies: 1
    Last Post: 03-17-2015, 11:01 PM
  4. Why isn't my S4 email showing?
    By AC Question in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 03-17-2015, 10:46 AM
LINK TO POST COPIED TO CLIPBOARD