1. Bobes23's Avatar
    Hi guys, I just got my new Cubot x11 from Etotalk. After the first startup there was an android update which I confirmed. After the update startup it said just ,,error" so I restarted the phone and then there is a pop up window "android is upgrading, optimizing apps 1 from 116 and thats all, there is no any progress even after 2 hours. If I restart the phone it's still the same. I can't pass over that to start the system. Anyone can help me?
    06-08-2015 03:14 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! You could try booting into Recovery Mode following the initial steps in this video:



    The problem is that after that, I can't help, since the menu is in Chinese. If you can figure out which option is Wipe Cache Partition, try that--maybe you could use Google Translate. You could also do Wipe Data/Factory Reset, if you're ok with wiping the phone.
    06-08-2015 06:55 PM
  3. Bobes23's Avatar
    I found the factory reset in the chinese menu, the problem is that it doesn't work. After restart it crashes and keeps the starting screen with the phone logo.
    06-09-2015 09:01 AM
  4. B. Diddy's Avatar
    Might be defective firmware or hardware, which wouldn't be that surprising for an off-brand device. Not sure what else to suggest, sorry!
    06-09-2015 03:25 PM

Similar Threads

  1. Replies: 1
    Last Post: 06-11-2015, 10:00 AM
  2. Replies: 3
    Last Post: 06-10-2015, 02:40 PM
  3. How can I stop incessant notifications in Google Keep?
    By Steven Friedmann in forum General Help and How To
    Replies: 2
    Last Post: 06-09-2015, 11:59 AM
  4. How do you update apps on a Samsung Galaxy Tab 3?
    By AC Question in forum Samsung Galaxy Tab 3
    Replies: 1
    Last Post: 06-08-2015, 08:09 PM
  5. New Android user - question on 4G?LTE
    By quizzer25 in forum ASUS ZenFone 2
    Replies: 3
    Last Post: 06-08-2015, 03:47 PM
LINK TO POST COPIED TO CLIPBOARD