1. vadnick's Avatar
    I have a Motorola Droid X on Verizon. During the day, it's on silent mode (with vibrate turned on). Overnight, I put it on a Motorola desktop docking station next to the bed with the alarm set.

    I bought it a couple days after release in July, and the alarm worked fine up until a couple months ago. The setting "Alarm in Silent Mode" is turned on. At the correct time, it would go off, with a bright red screen and the alarm song I chose.

    For the past couple months, however, there have been 3 or 4 times when it didn't work. The alarm doesn't play it's song. I wake up late to find the phone with the display off (not even with the clock that displays normally while it's attached to the dock). I press the power button, and there's the red alarm screen, flashing that it's time to get up, but still no sound. I go into the alarm settings to find that "Alarm in Silent Mode" is unchecked.

    I am 100% positive that I never changed the "Alarm in Silent Mode" setting. I reboot the phone at least 2 to 4 times per month, so that doesn't help. For several days in a row, I would check the settings before going to sleep to make sure that "Alarm in Silent Mode" was checked (despite having turned off/on the ringer during the day) and it always was, just like I set it. It's only in the mornings, when I wake up late for work, that I find it turned off.

    My best guess is that there is something happening overnight that it shutting it off from time to time. Maybe an update? Maybe another app? Maybe a virus? Something... I can't find any combination of doing what I do normally with the phone that turns off the "Alarm in Silent Mode" setting.

    I can bypass the problem by turning the ringer on before going to bed. But, I don't always remember, because I rarely use the ringer.

    Anyone else have this issue? Any thoughts on something I can try to duplicate it?
    01-26-2011 08:44 AM
  2. RUSH's Avatar
    I would suggest never to use your phone as an only means to waking you up. Secondly, if this is your only source of of alarm system you have - then you should by all means get the problem eradicated.

    Do this: From your home -screen tap menu - settings - applications - manage applications - all - clocks tap force stop clear cache, and data to see if that work.

    *Note*
    There is no app for alarm.
    01-26-2011 09:06 AM
  3. vadnick's Avatar
    Ok, we'll see what happens. I will set another alarm if I decide to test this fix.

    Also, it may have been coincidence, but last night, the phone was in silent mode, I put it on the dock and went into the alarm. I turned on my weekday alarm, and returned to the dock's home screen. Then, just after midnight, I noticed that the screen was off. I turned it back on, keeping the phone on the dock, and found the "Alarm in Silent Mode" setting turned off automatically again. So, I'm going to try to reproduce the problem the next time I'm up that late.
    01-31-2011 09:20 AM
  4. siliconeagle's Avatar
    There is a free app called silent mode timer that automatically turns off you silent mode. So you can set it before you go to bed and then in the morning the silent mode is automatically turned off.

    https://market.android.com/details?i...eb.silenttimer
    03-07-2011 07:11 AM
LINK TO POST COPIED TO CLIPBOARD