1. AC Question's Avatar
    Hello guys, I haven't found a thread exactly like my problem, so here it is. I have a 32 GB A-data Class 10 SD Card, which apparently doesn't seem to be detected ONLY in my phone (Samsung Galaxy S2). It worked fine, but I moved the phone while transferring data, interrupting the transfer and creating the problem. Now, that same card is detected on any other device, such as computers and other phones/tablets and is able to read/write data just fine, I even have some files on it right now. But my phone has trouble detecting it, when it's in there, it just says "Insert SD Card". Any ideas/help would be much appreciated, thanks guys ! Oh and formatting it didn't seem to solve the problem, I already tried that.
    08-31-2015 08:54 AM
  2. Golfdriver97's Avatar
    Welcome to the forums. Have you tried formatting it to something else and then back?
    08-31-2015 10:23 AM
  3. Cosmic Pie's Avatar
    What do you mean with "I moved the phone while transferring data"? Have tried with another card and then yours again? Sometimes it works..
    08-31-2015 11:12 AM
  4. mom4i4o's Avatar
    (I'm the guy with the problem)
    Well, I was copying a folder of images from my phone to my computer, and I accidentally moved the phone while the process was ongoing, which resulted in failure. After that, the SD card was not detected in my phone. I tried formatting, I will do that right now again and tell you what happens, hopefully it's gonna get fixed. And yes, the phone works fine with any other cards, it is just this one that causes issues. The card seems fine, it's detected anywhere else and is able to read/write data (copy/pasting files works) ... I'm ready to give up on it if it's not fixable and just buy another card, but at the moment I'm going to try,and,with your help, hopefully get that problem solved.
    08-31-2015 12:54 PM
  5. mom4i4o's Avatar
    Well guys, I have apparently fixed the issue, not by formatting the SD card, but by formatting the whole phone itself. Anyway, thanks for all the help, I really appreciate it. This is now solved.
    Golfdriver97 likes this.
    08-31-2015 02:24 PM
  6. Golfdriver97's Avatar
    Thanks for the follow up.

    From my Nexus 5.
    Android Central Ambassador Team Leader
    08-31-2015 04:23 PM
  7. Miller6386's Avatar
    As a work around in the future I believe clearing data and cache for media storage would have resolved this.

    Note 4tified
    08-31-2015 04:28 PM

Similar Threads

  1. Replies: 2
    Last Post: 09-01-2015, 04:37 PM
  2. Replies: 5
    Last Post: 09-01-2015, 11:21 AM
  3. How can I fix my phone so it will open text pictures?
    By AC Question in forum ZTE Android Phones
    Replies: 1
    Last Post: 08-31-2015, 10:27 AM
  4. Why am I not hearing the audio when I play YouTube videos?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-31-2015, 09:26 AM
  5. How can I get private mode working on my A5?
    By AC Question in forum Samsung Galaxy A5
    Replies: 0
    Last Post: 08-31-2015, 08:28 AM
LINK TO POST COPIED TO CLIPBOARD