1. AC Question's Avatar
    It seems my settings on Google Photos aren't sticky. I've set it to backup ONLY on wifi and that too while only charging. Yet, I see spikes in my data usage, via "Google Services". There was a few days when I was off the internet and I had took quite a deal of photos. When I was back online, "Google Services" used 2.3 GB in 1 day! Background Data. Somehow, despite my settings to use only Wifi, it seemed to backup over cellular data. It's happened afterwards too.

    Google Photos shows one setting in one screen and on clicking through, shows another. For example, in the Backup settings screen (in Google Photos app) it says "Upload Size: Full resolution that counts..." however that isn't what I selected. On clicking it, I see the second option selected i.e. "High Quality"

    So I don't know what setting is applied. If there was a way to post pics here I would. Anyone else face this problem?
    10-22-2015 05:54 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Here's how to post screenshots: http://forums.androidcentral.com/amb...d-central.html. You may have to register on the forum first.

    Do you know for sure if the phone is actually backing the photos up on mobile data? Try taking some photos with wi-fi off.
    10-22-2015 01:35 PM

Similar Threads

  1. Why does Google Play services drain my batter?
    By Psyycker in forum Moto X Play
    Replies: 14
    Last Post: 12-23-2015, 02:30 PM
  2. wanna ask about google play
    By Hendri kusliawan in forum Android Apps
    Replies: 9
    Last Post: 10-23-2015, 04:51 PM
  3. Replies: 1
    Last Post: 10-23-2015, 01:49 PM
  4. Replies: 5
    Last Post: 10-22-2015, 01:58 PM
  5. I get an Error when not connected to mobile data, what do I do?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 10-22-2015, 05:53 AM
LINK TO POST COPIED TO CLIPBOARD