Why am I being told your device isn't compatible with this version?

Printable View