1. AC Question's Avatar
    Hello I just got my new Leagoo Elite 1 and when I go to select wifi networks , it sees mine ,recognize as the best signal , but once I put in password and connect it just says saved, but doesn't connect .
    I have tried ot remove the wpa2psk and put free, still no success, I have ried rebooting , resetting , adding a direct mac address on router, nothing works , help I really have no clue to what else to do .
    I have also a signal from another network wifi unprotected around and it connects to it without problems ... so why doesn't recognize my netgear DNG2200v4 ? I have no issues with Iphone , Ipad, xbox and other friends devices when they come to my house, just this phone doesn't get to connect to my wifi network and its crazy !
    11-16-2015 06:47 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Make sure your router's DHCP range is wide enough (i.e., make sure there are enough IP addresses reserved for your devices). See here for more tips: http://forums.androidcentral.com/amb...-problems.html
    11-16-2015 01:12 PM
  3. aire235's Avatar
    Hi, I have the same problem... Have you solved your problem?
    01-10-2016 04:44 AM

Similar Threads

  1. Why would my Samsung Active 5 not keep time correctly?
    By AC Question in forum Samsung Galaxy S5 Active
    Replies: 2
    Last Post: 12-24-2015, 07:32 PM
  2. Going to Buy Nexus 6 need advice please (UK Model)
    By GeordieAffy in forum Google Nexus 6
    Replies: 3
    Last Post: 11-19-2015, 04:53 PM
  3. How to de-brand Moto G (2015) xt-1541
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 11-19-2015, 07:12 AM
  4. Why can't I send a text to a number that cost extra?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 11-16-2015, 01:17 PM
LINK TO POST COPIED TO CLIPBOARD