1. AC Question's Avatar
    When I connect my nexus to my pc via the usb, I used to be able to view all my photos in the DCIM folder. Now the DCIM folder contains 3 file folders - .thumbnails, 100ANDRO and browser-photos. The only one of these that appears to have any content is the thumbnails one, and that contains small versions of 'some' of the photos, as well as pictures that I have in downloads.
    How do I view the rest of my photos, so I can transfer them to my pc.
    Thanks
    01-17-2016 06:02 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Which Nexus device, and which Android version? When you connect via USB, swipe down the notification panel and tap the USB icon. Is MTP selected?
    01-17-2016 10:07 PM
  3. MJR48's Avatar
    It is a nexus 7 tablet. Yes, I have connected the USB. I can see everything on the tablet, but the photos are not in the DCIM folder where they used to be.
    01-17-2016 11:01 PM
  4. B. Diddy's Avatar
    If you use a file manager app on your tablet (like Total Commander), can you see a /DCIM/Camera directory, where any photos taken by the Camera would be stored?
    01-17-2016 11:25 PM
  5. MJR48's Avatar
    I don't use a file manager app.
    01-17-2016 11:51 PM
  6. B. Diddy's Avatar
    But I'm suggesting that you use one to look for that directory from within the tablet (rather than from the PC).

    Can you clarify--are the photos you're looking for ones that you took with the tablet's Camera app? Or did you transfer or download the photos to the tablet from somewhere else /DCIM?
    01-18-2016 12:32 AM
  7. MJR48's Avatar
    Sorry, yes, I have installed the file manager app and the photos (that is the ones taken with the camera app) . And with the file manager, the photos are within the DCIM folder, in a folder titled camera, right where I would expect them to be. But when I connect tablet to computer with USB, that camera folder is not within the DCIM folder
    01-18-2016 01:09 AM
  8. MJR48's Avatar
    To clarify - using the total commander app there is a folder titled DCIM
    Within that folder are separate folders called:
    .thumbnails
    100 ANDRO
    browser-photos
    Camera (this one contains the photos I want)
    PicPac
    prints

    When I connect to the PC, I can only see the folders:
    .thumbnails - which has pictures in it
    100ANDRO - which appears to be empty
    brower-photos - which appears to be empty
    01-18-2016 01:27 AM
  9. B. Diddy's Avatar
    When you connect to the PC, swipe down the notification panel and tap the USB icon. Is MTP selected?
    01-18-2016 01:50 AM
  10. MJR48's Avatar
    yes, it is
    01-18-2016 02:41 AM
  11. B. Diddy's Avatar
    This is dang peculiar. Can you try copying a few of those photos to a different directory (using your file manager app), and then seeing if they show up in Windows Explorer?
    01-18-2016 02:52 AM
  12. MJR48's Avatar
    thanks, I'll have a go at that once I have worked out how to use it
    Can you check back? Might take me a bit
    01-18-2016 03:56 AM
  13. MJR48's Avatar
    Ok, yes I can. I can move photos from the camera folder to the 100ANDRO folder (which was showing on the PC as empty) and they will show up on the PC in explorer. Does that help?
    01-18-2016 04:21 AM
  14. B. Diddy's Avatar
    So at least we know the problem isn't with the actual photo files, but rather the /DCIM/Camera directory. Let me test it out on my 2013 N7.
    01-18-2016 12:11 PM
  15. MJR48's Avatar
    cheers.
    01-18-2016 05:35 PM
  16. B. Diddy's Avatar
    Tested on my 2013 N7. /DCIM/Camera shows up in Windows Explorer. You have a 2013 N7, not 2012, right? Running Android 6.0.1?

    Have you already tried wiping the cache partition? http://forums.androidcentral.com/goo...tion-wipe.html
    01-18-2016 10:18 PM
  17. MJR48's Avatar
    According to the receipt, it is a Gen2 bought in Sept 13.
    As for 'have I already tried...? LOL, I am a totally ignorant about this stuff, I have no idea what I am doing.

    I will follow your wiping instructions and see what happens.
    You are awesome by the way.
    B. Diddy likes this.
    01-18-2016 11:43 PM
  18. MJR48's Avatar
    Sadly, I have cleared the cache as per instructions, but the camera folder is still MIA.

    Thank you for at least partially fixing the problem, as I can now use the file manager to drag and drop photos from the camera file into one of the folders that does appear on the PC, however I would still welcome any suggestions that will fix it altogether so I don't have to mess around with that step.
    01-19-2016 07:12 PM
  19. renzb's Avatar
    After trawling the Internet and trying all the suggestions (e.g. change transfer mode from MTP to PTP, turn USB debugging on/off, remove all drivers in Windows and re-install all drivers, use different/multiple PCs to prove it's not my specific Windows build, wipe the cache partition, restart the device, move to another directory in the DCIM folder, etc., etc), this is what I found actually works - at least for me.

    1. On your phone, using a file explorer (I used ES File Explorer, but any will do), create a new folder called DCIM2
    2. Navigate to the DCIM folder, select all files and folders
    3. Move everything to DCIM2
    4. Delete the DCIM folder (or simply rename it to DCIM-old if you're paranoid, but no real need for this)
    5. Rename DCIM2 to DCIM
    6. Connect phone to PC via USB, enable MTP mode. Open Windows Explorer and navigate to the DCIM folder.
    7. Bam! All photos and videos and folders are there! ...and appears to be a permanent fix!
    8. Take a new photo - confirm it shows up perfectly in the correct folder both on your phone and in Windows Explorer on your PC
    9. Do a jig because you're so happy now


    Now I'm not sure what Android 6.0.x did to the DCIM folder permissions or transfer cache or whatever, but this method has permanently fixed the problem for me (and also for other, similar folders).

    I wasted WEEKS trying to find the solution and this is not mentioned anywhere else on the first 20 pages of any Google search result or forum I've been able to find so far.

    Hope it works for you!
    B. Diddy likes this.
    08-06-2016 01:38 AM
  20. MJR48's Avatar
    Dear renzb,
    You are possibly the most awesome person on the internet today! It has been 8 months since I found this problem and I have been unable to solve it, other than by transfering photos to the 100ANDRO folder, which is a pain to say the least, especially as I am currently on an overseas holiday and wish to save quite a lot of photos and videos from the tablet. I had forgotten all about this thread until it popped up on my email notifications this morning. I have just tried your solution and IT WORKS! ! I am doing a full on happy dance, not just a jig!
    Thank you thank you thank you for taking the time to share your solution. <3
    Interestingly, the existing photos on the tablet do not show in the new folder, only ones I have taken to try it out just now, but as I have already saved those through my previous laborious method, that does not matter.
    You have fixed my problem and I am extremely grateful.
    08-06-2016 03:18 AM
  21. KOTENKOTUOI's Avatar
    Another temporary solution

    With phone connected to the computer w/ USB > MTP selected
    - Using ES File Explorer, Home Screen > click on (arrow down located between IMAGES & MUSIC icon)
    - Choose View on PC > Turn On > FTP address will now show up
    - Type the ftp://<ip addressort> on onto your PC Window Explorer address bar
    - Viola! The CAMERA folder now should show up inside of DCIM folder. However, I can't see the thumbnail preview but files can be copied on to your PC just as normal.

    Good Luck!
    08-09-2016 12:07 AM
  22. Paulo Carvalho1's Avatar
    This problem showed up today and luckily with your help I solved it already!!!!
    10-09-2016 09:17 PM
  23. Ahmed Abo Elella's Avatar
    Please renzb,

    After following your advice .. And after making new dcim2 folder and cutting files from original dcim folder and pasting in dcim2, MOST of my photos are gone in the pasting process without any interference being done by me or by the phone ...

    Now I can't retrieve these photos at all .. They are very important to me .. Please, please, help me to retrieve these photos ........
    05-13-2018 05:09 AM

Similar Threads

  1. Why do some Galaxy Tab s devices show 49 days on ultra power saving mode?
    By AC Question in forum Samsung Galaxy Tab S 8.4
    Replies: 1
    Last Post: 01-22-2016, 07:59 AM
  2. Replies: 1
    Last Post: 01-17-2016, 10:15 PM
  3. Replies: 1
    Last Post: 01-17-2016, 10:12 PM
  4. Can I use a Galaxy S6 Edge Plus on Straight Talk?
    By AC Question in forum Samsung Galaxy S6 edge+
    Replies: 1
    Last Post: 01-17-2016, 06:39 PM
  5. How do I save document to microSD card on Galaxy Tab 4?
    By AC Question in forum Samsung Galaxy Tab4 7.0
    Replies: 1
    Last Post: 01-17-2016, 06:01 PM
LINK TO POST COPIED TO CLIPBOARD