1. AC Question's Avatar
    First of all, I have read a lot of threads and tried many methods in fixing this problem. Here are the methods I tried: reformatting the SD card to default using my PC, reformatting the SD card to FAT32, using testdisk to recover partitions, and formatting it in the phone itself (all of these were suggested in threads). And although I'm getting more knowledgeable about SD cards, this problem still arises.
    ok...now for the specifics. I am using a 64GB SanDisk Ultra PLUS microSDXC (UHS-1 and Class 10), and my LG Stylo is able to detect and format the card. However, when i power off and restart my phone, it will display "SD card is blank or has unsupported file system." When this happens, I'm unable to access my files (don't worry, i backed them up on my PC) and my phone is telling me i should format it (I have followed through on this, but it still arises if i power off my my phone), I have learned that if you remove the SD card and put it back in, then it will return back to normal. My problem is that this is really a hassle if i had to do this every time my phone powered off completely. The last resort for me is to avoid powering off completely, and everything will most likey be fine. However, I am asking this question right now to find out if there is a loophole in fixing this problem. Otherwise, I guess i just have to deal with this very annoying hassle. Please reply if you have some insight....(I am pretty inexperienced in technology)
    01-18-2016 02:51 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! First, good for you that you're backing things up! You'd be surprised at how often people don't do that.

    Second, does this happen with any other card? If it only happens with this card, I'd be concerned that it's either corrupt or failing. Unmount it in Settings>Storage, remove it, and insert it into your computer and run chkdsk to look for bad sectors: http://forums.androidcentral.com/amb...d-sd-card.html

    Another possibility is that the card is counterfeit. Run SD Insight to check its validity.
    01-18-2016 03:19 AM
  3. MadeAccountToReply's Avatar
    Thanks for the reply. I am the person who asked this question, but i made an account to reply.
    I followed through on both tests. The chkdsk test resulted in "Windows has scanned the file system and found no problems. No further action is required." The SD Insight test proved that the SD card is not counterfeit, and that it is legit. I tried another sd card in my phone and the same problem arises.
    01-18-2016 05:47 PM
  4. B. Diddy's Avatar
    In that case, it may be a problem with the firmware or the hardware. The Stylo is supposed to get Marshmallow some time soon--has yours gotten the update?

    Also, see if this happens in Safe Mode: https://support.t-mobile.com/docs/DOC-21843. If it doesn't, that suggests a 3rd party app is causing this problem.
    01-18-2016 11:24 PM
  5. MadeAccountToReply's Avatar
    Ok! I did the Safe Mode Test, and the problem doesn't arise! I am able to access the files of the SD card. Once I went out of safe mode, then the notification of "unsupported filesystem" appears. To answer your first question, my phone is still on Lollipop (5.1.1) and there are no new updates yet.
    I am not sure on what to do from here, but it seems like we have found the problem. Now, I will wait for your guidance!
    01-19-2016 09:08 PM
  6. B. Diddy's Avatar
    This is the tedious part--reboot into normal mode, and then uninstall apps one by one until the problem goes away. To keep track of things more easily, you may want to uninstall an app, see if you can access the SD card, and then reinstall the app again if it still doesn't work (since that app most likely wasn't the issue).
    01-20-2016 12:23 AM
  7. MadeAccountToReply's Avatar
    Ughh... So before I started deleting apps...I tested the Safe Mode check once more, and the problem appeared. I did this two more times, and the problem appeared both times. This is so weird because I did three tests earlier, and in Safe Mode, I could still access files from the Sd Card, but now I can't. What happened? I'm sorry for this trouble, and any time that you wasted.

    I have a new question. I tried searching for the answer, but couldn't find it. Can the LG G Stylo read an exFAT SD card? It has been on FAT32 all this time because of my conversion. and I am going to change it back to exFAT because it seems like my phone can read it (based on when i first put the SD card in my phone) and I would prefer it to be in exFAT.However, I heard that some phone can only read FAT32.

    About the original problem.
    Do you have any advice on what I should do now? The "unsupported file system" notification appears in Safe Mode. Was there any reasons on why my phone turned 180 degrees on me?
    I didn't do anything between the tests, besides looking at the apps I was about to start deleting in Settings>Apps and normal usage like listening to music/using the browser.

    Thanks again for your help
    01-20-2016 03:48 AM
  8. B. Diddy's Avatar
    I'm starting to think it's either a firmware issue (either a bug in the code or corruption) or a hardware issue (problem with the SD reader). Use a can of compressed air to blow out the SD slot, and then see if you can clean its contacts with a small cotton swab and rubbing alcohol.

    I'm not sure if the Stylo can read exFAT--I've never been able to find any reliable source that reports which phones can read what kind of filesystem on a microSD. FAT32 should be universally compatible, but exFAT isn't.
    01-20-2016 12:04 PM
  9. MadeAccountToReply's Avatar
    What do you mean by its "contacts"?

    Also, when you bring up hardware, the phone did have a problem with the brightness when a bit of water got into it. I disassembled the parts (making sure to to remember where everything goes) to let it dry. I used a paper towel to dry most of the water, then left it overnight on my desk. The next day everything was working correctly again when i put it back together, nothing was broken
    Could this be an issue...?
    01-20-2016 06:39 PM
  10. B. Diddy's Avatar
    Ding ding ding!!! I think we have a winner ... water exposure can cause all sorts of unpredictable damage that might not show up immediately, since leftover moisture that may be difficult to get rid of completely can cause some insidious corrosion. So things might have worked initially after you thought you dried it all off, but the leftover moisture may have started causing slow corrosion somewhere.

    The contacts I'm talking about are the contacts of the SD reader, which touch the contacts on the SD card. It's entirely possible that there's corrosion there, or perhaps along the connections on the motherboard. I'm not sure if you can do anything about this besides bringing it to a repair shop for further diagnosis. If they do find water damage, it may be hard to fix, since if they replace one component, they may not be able to completely rule out water damage somewhere else.
    01-20-2016 07:25 PM

Similar Threads

  1. I rooted my lg g2 and I want to install lollipop how do I do it?
    By ed368 in forum LG G2 Rooting, ROMs, & Hacks
    Replies: 2
    Last Post: 01-19-2016, 01:55 PM
  2. Replies: 5
    Last Post: 01-18-2016, 01:13 PM
  3. App icons have changed and want them back linked to a theme
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-18-2016, 03:29 AM
  4. Replies: 1
    Last Post: 01-18-2016, 03:20 AM
  5. Why doesn't Google Voice typing work when I am offline?
    By androidmatcha in forum Samsung Galaxy S3
    Replies: 0
    Last Post: 01-18-2016, 01:44 AM
LINK TO POST COPIED TO CLIPBOARD