1. AC Question's Avatar
    When I record a video using the camera on my phone or using a screen recorder, I am unable to watch them back. The video file is not corrupt because if I email it to myself I am able to watch it on my computer, and when I look at it in the gallery it shows me a thumbnail of the video. I'm not using any third party software, it's literally just recording a video with the camera and then viewing it in the gallery. Videos are saved directly to the phone, no SD card, and I even tried deleting a ton of pictures and uninstalling a couple apps I didn't use to clear space but still no solution. Black screen with white text stating "Can't play video." Any help or ideas would be greatly appreciated!

    As a side note, I have tried
    -Restarting the phone
    -Turning the phone off and removing the battery
    -Turning the phone off and removing both the battery and sim card (carefully)
    01-30-2016 03:00 AM
  2. BRob72's Avatar
    I was having this exact same issue and I was about to reset my phone out of frustration but I found the culprit! There was a Google+ update that was installed recently... I uninstalled it and tried to play a video from the Gallery... it gave me the option to select the App that I wanted to use to play the movie (something that wasn't happening with the error)... I chose Photos and it worked with no further issues!
    The reason I decided this Google+ update was the next target of my troubleshooting was that when the "Can't play video" message came up there was a red header on the screen and I knew this was the Google+ header color (none of my other apps have this color header) so I took a shot and it worked
    Hope it works for you too!
    Laura Knotek likes this.
    01-30-2016 11:40 AM
  3. bmahogany's Avatar
    Worked like a charm, thanks!
    01-30-2016 04:32 PM
  4. BRob72's Avatar
    No worries glad to hear it worked for you

    Posted via the Android Central App
    02-02-2016 12:51 AM
  5. livingecho's Avatar
    I was able to assist a work colleague using your solution. It worked perfectly. Thank you!
    02-09-2016 11:13 AM
  6. M Power's Avatar
    I was having this exact same issue and I was about to reset my phone out of frustration but I found the culprit! There was a Google+ update that was installed recently... I uninstalled it and tried to play a video from the Gallery... it gave me the option to select the App that I wanted to use to play the movie (something that wasn't happening with the error)... I chose Photos and it worked with no further issues!
    The reason I decided this Google+ update was the next target of my troubleshooting was that when the "Can't play video" message came up there was a red header on the screen and I knew this was the Google+ header color (none of my other apps have this color header) so I took a shot and it worked
    Hope it works for you too!



    Hi i did all the steps but it didn't work
    I have a t-mobil phone an xperia z3 i am using it abroad but whenever i record a video it will play a lil bit but then when i open the file it says can't play video
    Any other suggestions or am screwd
    Thank you
    07-03-2016 07:53 PM
  7. B. Diddy's Avatar
    Hi i did all the steps but it didn't work
    I have a t-mobil phone an xperia z3 i am using it abroad but whenever i record a video it will play a lil bit but then when i open the file it says can't play video
    Any other suggestions or am screwd
    Thank you
    See response in your other thread: http://forums.androidcentral.com/son...ml#post5250167
    07-05-2016 03:40 PM
  8. FATMama82's Avatar
    The same thing happened to my idol3 touch phone. I did stuff the community told me to do & lost all my pics. Found them on google+ archive but they would not allow me to put them back under my pic app. I tried everything. I disabled GOOGLE+ and they all came back and my videos are working
    03-04-2018 02:55 PM
  9. kfogel's Avatar
    BRob72, thank you! This also fixed the problem for me -- I had been at my wits' end.
    05-18-2018 06:12 PM

Similar Threads

  1. Replies: 52
    Last Post: 07-07-2019, 05:10 PM
  2. Why won't my Razr M charge?
    By AC Question in forum Droid RAZR M
    Replies: 1
    Last Post: 01-30-2016, 03:03 AM
  3. Replies: 0
    Last Post: 01-30-2016, 02:56 AM
  4. Why isn't the time correct on my phone while in the Canary Islands ?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 01-30-2016, 02:55 AM
  5. Why does not my Go Clever Tab r83.2 turn on?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 01-30-2016, 02:46 AM
LINK TO POST COPIED TO CLIPBOARD