1. AC Question's Avatar
    Hi folks, i have a Hudl 2 which will not power up or recognise charger. I have tried different chargers and tried the usual start/volume up scenarios and nothing. I have had it on charge for 24 hours and still nothing. Even tried removing the battery, inspected the charge port etc.

    So my question is, is there anyway to manipulate it or reinstall firmware from a PC while it is in this dead state. I have read that there have been problems with Hudl2 and lollipop, which may have updated unknowingly.

    Thanks
    02-11-2016 09:21 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! If the device is powered off and it isn't charging, then I don't think reinstalling the firmware will help, because it sounds more like a hardware issue. It could be a faulty USB port, dead battery, or faulty motherboard. I'd bring it to a repair shop.
    Rukbat likes this.
    02-11-2016 04:09 PM

Similar Threads

  1. Replies: 4
    Last Post: 02-12-2016, 11:25 AM
  2. Replies: 5
    Last Post: 02-11-2016, 10:07 PM
  3. LG G3 Resolution messed up - how to stop processes on startup?
    By justimpressive in forum General Help and How To
    Replies: 1
    Last Post: 02-11-2016, 05:52 PM
  4. Replies: 1
    Last Post: 02-11-2016, 04:15 PM
  5. How can I hide photos or videos on my Samsung Galaxy S Dous S3?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 02-11-2016, 04:31 AM
LINK TO POST COPIED TO CLIPBOARD