1. dr_fone's Avatar
    I was having a lot of problems with auto connecting to open wifi networks

    Basically been working at same place for years, so had the same journey in to work on the tube (or the subway if you're in the States!) and when I had my iPhone or my Nexus with pure Android, I could stop connecting to unknown networks. But since I bought my S6 Edge+, its been very irritating because there's so many BT Openzone networks that my phone was automatically connecting to and the only way was to switch off my wifi. The problem is when I get home and I've forgotton, it burns through my monthly data allowance when I'm watching movies on my phone.

    So....

    What you do is when you phone connects to an open network, go to Settings > WiFi and select the network you have connected to, press and hold to go into advanced settings / Manage network settings and for the network, select Static IP, and put in a static IP and subnet mask (something like 19.8.2.5 and 255.255.0.0). Once you save this, you phone will try to use a specific IP for that network, and it won't work. So you phone can't connect.

    This won't affect connecting to your network at home, it will only be with the annoying open networks that your phone keeps trying to connect to.
    You will however need to do this for every network on your journey that you auto connect to

    Hope this helps someone!
    12Kels likes this.
    02-28-2016 10:53 AM
  2. DenverRalphy's Avatar
    Have you tried going to Settings - WiFi - More (top right corner) - Advanced, then turn off Passpoint connections? Your device should only automatically connect to Passpoint Certified WiFi networks. And if you turn that option off, you won't automatically connect to any Wifi network.
    Laura Knotek likes this.
    02-28-2016 03:33 PM
  3. dr_fone's Avatar
    Thanks for the reply. I'm not getting that option on my Galaxy S6 Edge+, I don't see Advanced when i go to More
    03-01-2016 05:19 AM
  4. tardus's Avatar
    IMO connecting to unsecured wireless networks is not a good idea. I unchecked on my LG G4. It should also reduce battery consumption a little.
    03-08-2016 12:16 PM

Similar Threads

  1. Best dongle for mirroring screen to non-smart TV?
    By Vectorspace in forum Samsung Galaxy S6
    Replies: 21
    Last Post: 07-29-2016, 02:09 AM
  2. Why does my Samsung Galaxy S5 have touch screen stop working?
    By AC Question in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 02-28-2016, 04:32 PM
  3. i forgot my pin for galaxy note 4, pl help to reset
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-28-2016, 04:27 PM
  4. iTunes music to Android no problem?
    By AC Question in forum General Help and How To
    Replies: 3
    Last Post: 02-28-2016, 02:09 PM
  5. how to dissablae talkback on android
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-28-2016, 10:35 AM
LINK TO POST COPIED TO CLIPBOARD