1. menappi's Avatar
    Phone: Blu Life ONE X2
    OS: 6.0.1

    I have a few homepage widgets (Google Keep, Poweramp, Bacon Reader, Chronus) and every time I reboot my phone the widgets (all except Chronus) will just show a blank box where the widget is supposed to be but the widgets themselves won't load. Sometimes Bacon Reader will eventually load up but typically I need to delete each widget and re-add it to my homescreens and it's getting tiring. Anyone have any ideas or things to check? I've tried deleting my launcher data/cache (Apex Launcher) but that did nothing.
    02-02-2017 06:02 PM
  2. B. Diddy's Avatar
    Does that happen on the stock launcher as well? If not, then it may be a widget compatibility issue with Apex. Alternate launchers usually don't guarantee that all widgets will work correctly.
    02-03-2017 11:59 AM
  3. menappi's Avatar
    You know what, I haven't tried switching back to the stock launcher. Spent too much time organizing this one but I am going to try that later.
    02-03-2017 12:14 PM
  4. menappi's Avatar
    Tried various other launchers and the issue is still there, the widget window, upon reboot, just shows a faint outline where it should be but won't load. What's weird though is that if I just leave it sometimes, it may load after an hour or two. On one widget (poweramp) I can get the widget to populate if I load the app or if I plug in my headphones (and music starts to play). With Google Keep also, if I load the actual app and edit a note the widget will sometimes start to show what it should. Any ideas why they won't load themselves like they should?
    02-04-2017 02:51 PM
  5. B. Diddy's Avatar
    Did you also try the stock launcher? If that still doesn't work, then try wiping the system cache partition. Follow these steps, but make sure you select Wipe Cache Partition, and not Wipe Data: BLU Life One X2 | Recovery-Mode.com
    02-04-2017 06:55 PM
  6. menappi's Avatar
    Tried the other launchers and it's the same issue. Ive used Apex launcher though on my previous phones and always had these 3 desktop widgets and have never had issues before so I can't imagine it's the launcher. I also did try wiping the cache partition a few days ago and it didn't seem to help the issue. Ugh.
    02-05-2017 01:42 PM
  7. B. Diddy's Avatar
    When you say you tried the other launchers, I'm assuming you're including the stock launcher.

    It's odd behavior, that's for sure. Do you have any power-saving modes turned on, or do you have Restrict Background Data turned on in Settings>Data Usage​?
    02-05-2017 09:36 PM

Similar Threads

  1. Replies: 2
    Last Post: 02-03-2017, 09:48 AM
  2. USB Type C to C didn't work until reboot
    By kenorian in forum Google Pixel & Pixel XL
    Replies: 4
    Last Post: 02-03-2017, 03:40 AM
  3. Replies: 0
    Last Post: 02-02-2017, 04:26 PM
  4. Replies: 0
    Last Post: 02-02-2017, 04:03 PM
  5. Replies: 2
    Last Post: 02-02-2017, 02:03 PM
LINK TO POST COPIED TO CLIPBOARD