1. 1rj2's Avatar
    My friend has a S4 mini and a Tp-link TL- WR841N. He has about 4 devices connected (2 phones and 2 laptops) and when he connects his phone to the WiFi it works for about 5 min then stops working on his phone and for everyone else, if he disconnects his phone then everything goes back to normal.

    So far we have tried changing de DNS server and rebooting the WiFi, but still have no idea what may cause this.

    Thank you in advance for any help.
    04-10-2017 09:57 PM
  2. SpookDroid's Avatar
    Does he have Bluetooth on while connecting to the router? Try turning that off. Have you checked to see if the TP Link router has any firmware updates available? Some Samsung devices are weird with WiFi unless the latest firmware is flashed.

    I'd also try changing the WiFi channel on the router and seeing if that helps.
    tangjingyua2n likes this.
    04-10-2017 10:11 PM
  3. ashleedawg's Avatar
    It took me forever to realize that it was a battery saver app (Avast, in my case) that was always shutting off my WiFi, screen rotation, and more. I fixed it by turning off the app's WiFi Optimization in Profile setting.
    05-24-2017 09:38 AM

Similar Threads

  1. v20 video upside down on tv
    By recDNA in forum LG V20
    Replies: 2
    Last Post: 04-14-2017, 09:52 AM
  2. Need help WiFi calling
    By cardboard60 in forum Samsung Galaxy S7 edge
    Replies: 5
    Last Post: 04-11-2017, 04:33 AM
  3. Samsung S6 edge+ battery drain overnight!!!
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-10-2017, 11:36 PM
  4. Galaxy S6 - Reboots when connected to charger
    By ctindman in forum Samsung Galaxy S6
    Replies: 3
    Last Post: 04-10-2017, 11:33 PM
  5. Why does my note 4 keep turning wifi off?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-10-2017, 08:02 PM
LINK TO POST COPIED TO CLIPBOARD