1. rickspain's Avatar
    Hi - I have a new Cubot Rainbow running Android 6 Marshmallow. I cannot get the phone to cast to either my Chromecasts using either Photos app or Home app. Phone just either hangs or connects and instantly disconnects. Tested old Cubot S208 - that still works. Tested 2 other identical Phones with same result - none of them will cast. Old S208 running Kitkat 4.4 works a treat. Is it the phone or Marshmallow - I did read somewhere that Google had a problem around December 2016 with Photos app not casting. Ant takers?
    05-29-2017 01:59 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Moved from the Galaxy S3 forum to the General Help forum (since you're asking about a Cubot phone).

    If you open the Google Home app on the phone, does it show the details of the Chromecast devices there correctly?
    05-29-2017 10:48 PM
  3. rickspain's Avatar
    It does display devices correctly. It won't cast the phone, but it will cast utube and Netflix.
    05-30-2017 02:22 AM
  4. B. Diddy's Avatar
    Sorry, but what do you mean that it won't cast the phone? Do you mean that there isn't a Cast Screen option available? Or as you mentioned in your first post, do you mean that Google Photos app won't cast?
    05-30-2017 03:16 PM
  5. rickspain's Avatar
    On my old phone, running Android 4.4, I could cast the phone which meant everything I saw on my phone was also shown on the TV. It was also possible to cast a photo or video directly from the Gallery. On my new Cubit Rainbow, the Home app will not cast the phone. It connects and then instantly disconnects. TV says ' your device has disconnected'. Trying to cast photos from Photos app hangs the phone and I have to reboot.
    05-30-2017 03:43 PM
  6. B. Diddy's Avatar
    Go to Settings>Display​. Is there a Cast option there?
    06-03-2017 11:49 AM
  7. rickspain's Avatar
    No. No casting options in display under settings.
    06-10-2017 12:27 PM
  8. rickspain's Avatar
    I have no problem with casting Netflix or Utube from their respective apps on the phone. I have downloaded an app that will cast photos and videos, but its nowhere near as good as Gallery was.
    06-10-2017 12:32 PM
  9. B. Diddy's Avatar
    Was Google Photos preinstalled on the phone, or did you have to install it yourself? If it was preinstalled, see what happens if you boot into Safe Mode. On most Android devices, while powered on, press and hold Power until the Power Off menu appears. Press and hold the Power Off selection until the Safe Mode prompt appears. Tap OK.
    06-13-2017 12:10 AM
  10. rickspain's Avatar
    In safe mode I get almost that same result. Chromecast switches on but gets no further. It just displays it's screen saver. No acknowledgement.
    06-14-2017 04:34 PM
  11. B. Diddy's Avatar
    Hmm, running out of ideas here. Have you already tried rebooting the Chromecast? If that doesn't help, also consider factory resetting the Chromecast.
    06-14-2017 05:44 PM

Similar Threads

  1. Galaxy a5 2016 doesn't install marshmallow update
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 05-29-2017, 10:26 AM
  2. DOWNLOADINF Problem in Playstore
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-29-2017, 08:07 AM
  3. Replies: 0
    Last Post: 05-29-2017, 02:52 AM
  4. Replies: 0
    Last Post: 05-29-2017, 02:52 AM
  5. Replies: 1
    Last Post: 05-29-2017, 01:42 AM
LINK TO POST COPIED TO CLIPBOARD