1. rezei66's Avatar
    Two days ago my Edge started crashing after I flashed a stock firmware. I selected the correct one and Im sure nothing went wrong during the process. Now, whenever I try to boot the phone is just turns off after the splashscreen. I might add that no LEDs are lit up during that aswell. I tried accessing the recovery but once reaching the blue "Installing update..." screen the phone turns off aswell. It doesnt let me past that point.

    The only thing that works is the bootloader or download mode. I tried flashing older firmware aswell with no progress.

    Might this be a hardware issue?
    03-15-2018 11:07 AM
  2. rezei66's Avatar
    Dammit. S7 Edge*
    03-15-2018 11:10 AM

Similar Threads

  1. I have no sound with texts on galaxie s9
    By Android Central Question in forum Samsung Galaxy S9 & S9+
    Replies: 28
    Last Post: 09-24-2018, 08:49 AM
  2. Schedule messages from a Samsung Galaxy s9+
    By Android Central Question in forum Ask a Question
    Replies: 4
    Last Post: 09-16-2018, 07:34 AM
  3. Replies: 1
    Last Post: 03-21-2018, 11:41 AM
  4. How many bt headphones can I connect to one S9/S9+? And How?
    By Hirak Sarkar in forum Samsung Galaxy S9 & S9+
    Replies: 13
    Last Post: 03-20-2018, 10:42 AM
  5. Replies: 1
    Last Post: 03-15-2018, 04:02 PM
LINK TO POST COPIED TO CLIPBOARD