1. rkhanso's Avatar
    I have a Google (Motorola) Nexus 6 phone.

    The Smart Lock - location feature used to work great. The phone would not lock at home and work. But it quit working sometime recently (the last 1-3 months).

    Another feature that stopped working is the OK Google wake-up phrase.

    I have contacted Google support on both issues. They weren't able to help me and referred me to Motorola, who wants to replace my phone at a charge to me - saying it's a hardware problem.

    Working with Google support, they wanted me to un-install updates to the "Google" app, then the OK Google feature starts working again- that is, until that "Google" app gets updated again.

    However, the 2nd time I did a factory reset, I told it to start fresh and not restore a backup. So far, the "OK Google" feature seems to be working, even after the Google app was updated. Odd. And, this does not seem like a hardware problem to me.

    Regarding the Smart Lock location feature...... I no longer even see the option for setting a location on the phone.

    I've done a factory reset and the location option for Smart Lock still doesn't show up.

    Did an update stop these features from working? Any suggestions on things to try?

    I'm currently at a factory re-set phone with only Dropbox added so I can share files with my PC. I was able to get OK Google working again after the factory reset without restoring all my previous data.
    Attached Thumbnails Google Nexus 6 - no more smart-lock location option? Also - OK Google problems-screenshot_20180523-113918.jpg  
    05-23-2018 12:01 PM
  2. SpookDroid's Avatar
    Yeah, the Location option is officially gone, I'm afraid. Sorry.
    05-23-2018 12:22 PM
  3. rkhanso's Avatar
    That sucks about the location Smart Lock.

    I might have found at least part of the problem for OK Google.
    I've always used the paid version of Nova Launcher.
    I just installed it and then OK Google stopped working.


    Well, maybe that's not it.

    Now, for some reason this Voice Match thing keeps popping up and wanting me to record "OK Google" 3x again. It's stuck in a loop over and over.

    Before I installed Nova Launcher, or said OK to use Google Assistant, the "OK Google" feature was working.

    This is getting frustrating, as it seems to be all over the place on what is causing the problem. Though, I just may not understand how it's all related.

    Any suggestions?
    05-23-2018 12:22 PM
  4. SpookDroid's Avatar
    Try using the stock launcher and see if Nova is, indeed, causing issues. And make sure you don't have any other apps that are 'always listening'.
    05-23-2018 12:29 PM
  5. rkhanso's Avatar
    Try using the stock launcher and see if Nova is, indeed, causing issues. And make sure you don't have any other apps that are 'always listening'.
    I kept the Google launcher and "OK Google" worked all yesterday after the factory reset. I didn't even install Nova Launcher.

    Today, it quit working again, and I keep getting this new popup app "Access your Assistant with Voice Match" and it wants to train my voice model. I say "OK Google" 3x for it to train. It doesn't give anything at the end, it just goes away. No button to "Finish" or continue on.

    Then, the next time I say "OK Google" that same "Access your Assistant with Voice Match" screen comes back and wants me to record "OK Google" 3x again. This happens over and over.

    Speech-to-text works, because when I touch the microphone on the keyboard or search bar, the phone understands what I'm saying and searches or types what I say. It's just that OK Google quit working.

    I'm thinking some update is causing this, right? Especially since "OK Google" worked OK for an entire day.

    Any suggestions?
    05-24-2018 08:16 AM
  6. rkhanso's Avatar
    I did a little more troubleshooting.
    It's not Nova Launcher causing the problem.
    It seems to be whenever I long-press the home button for Google Assistant, that starts the Voice Match thing to come up. Or maybe when I turn on the "have OK Google wake up the phone when it's sleeping" feature. I'm not sure which one, but it seems to be one of those things that cause the problem.

    In the end, it's that Google Voice Match thing I think that never "finishes" after I record my voice saying "OK Google" 3x.

    Has anyone else had this problem?

    My phone is a older one - Nexus 6 by Motorola.
    05-27-2018 08:42 AM

Similar Threads

  1. No Sprint, huh?
    By Larry 609 in forum HTC U12+
    Replies: 11
    Last Post: 07-13-2018, 09:12 AM
  2. Replies: 10
    Last Post: 06-09-2018, 10:59 PM
  3. bypassing lock screen of a zte max 3 without having the sims card?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 05-23-2018, 11:52 AM
  4. How can I lock screen when answering phone calls?
    By hkkc in forum Ask a Question
    Replies: 1
    Last Post: 05-23-2018, 11:06 AM
  5. LG G7 Smart case
    By Android Central Question in forum LG G7 ThinQ
    Replies: 0
    Last Post: 05-23-2018, 10:34 AM
LINK TO POST COPIED TO CLIPBOARD