1. thezob101's Avatar
    So I bought the G1 from a friend a couple of months ago and I have the Prepaid Sidekick Plan so of course the internet didn't work. I knew that the SK APN is hiptop.t-mobile.com so I put it in a new APN along with my SK username and password, and my internet worked perfect. After that I went to Virginia for a week and there was no service, but when I would travel to places and get service, my internet wouldn't load. So now I'm back in RI with no internet on my phone. It shows the Edge/3G symbol, and when I try to load something it mostly does the arrow up on the symbol and sometimes up and down, but it doesn't load anything web-related. I've tried messing with the APNs and turning my phone on and off; all that stuff.
    Anyone have any suggestions?
    10-28-2009 08:21 PM
  2. Rusty Shackelford's Avatar
    A while back I switched from the Blackberry 8900 to a unlocked iPhone. Had a similar experience where it worked for a few days, but then stopped. After an hour or so talking to tech support it was fixed.

    The problem in my case (which sounds similar to yours) was not an issue with the settings on the device, but the provisioning within the tmobile network. The network has the ability to determine what device you are using, and if it detects you are not using a data plan that matches the device, it will disable your data until proper provisioning has occurred on the network.

    I would say give customer service a call and get the network provisioning switched from sidekick data to G1. Hopefully this helps. Good Luck in finding a solution.
    10-30-2009 07:15 PM
  3. thezob101's Avatar
    A while back I switched from the Blackberry 8900 to a unlocked iPhone. Had a similar experience where it worked for a few days, but then stopped. After an hour or so talking to tech support it was fixed.

    The problem in my case (which sounds similar to yours) was not an issue with the settings on the device, but the provisioning within the tmobile network. The network has the ability to determine what device you are using, and if it detects you are not using a data plan that matches the device, it will disable your data until proper provisioning has occurred on the network.

    I would say give customer service a call and get the network provisioning switched from sidekick data to G1. Hopefully this helps. Good Luck in finding a solution.
    Thanks a lot I was kind of thinking along the same line I think I'm going to try to pop my SIM in a Sidekick and call T-Mobile up complaining of no internet and see where that gets me because tech support gets angry when you say you're using another phone other than the Sidekick when you're on the Sidekick plan.
    integra94 likes this.
    10-30-2009 09:03 PM
LINK TO POST COPIED TO CLIPBOARD