1. andromike's Avatar
    hi

    firstly... hi to the forum

    i have a samsung s5 mini(g800f) running android 6.01 on build no. MMB29K.G800FXXU1CRG3 with baseband G800FXXU1CRG3 and i am rooted.

    the issue is that my wifi will not stay connected to my home network it will disconnect every 30secs or so and eventually will give message on access point name of internet not available, but it is and for the short time its connected internet is available

    i have been outside to hotspots and it connects and stays connected, strangely last night i was at a hotspot and since coming back home it connected streight away and has remained connected so far(approx 12hrs).but this has happended before and at some point it will disconnect

    i have done/tried the following fixes to sort this but nothing seems to work..i list them below

    re flashed to the previous version of android before the ota update to 6.01
    re flashed back to 6.01
    flashed different baseband versions
    assigned static ip address
    disabled captive portal detection with commands settings put global captive_portal_mode 0 using terminal and also with command captive_portal_detection_enabled 0
    changed captive portal server to localhost
    wifi sleep option to always on
    smart network switch disabled

    i tried connecting to my girlfriends access point from her samsung s6 she had not much signal for mobile data and it disconnected..

    my theory is the phone is checking the quality of the internet connection and deeming it not fit and so disconnecting even though the option of smart network switch is disabled, i think this also because i cant connect to a wifi signal that has no internet connection for example

    i think for it to check the internet it must be sending a ping to an outside server and either it is unreachable or there is a timeout value that is too small and so if it takes too long it deems the connection unusable,

    the internet at my home is significantly slower than outside hotspots as i live rural and have a broadband speed of max 4.5mbs

    does anyone know of where the code is that would cause this sort of connection quality check and if its possible for me to disable or modify it manualy

    im on a bt smart hub 6 router

    thanks

    hope someone can help as its driving me mad now
    11-09-2018 08:14 AM
  2. Rukbat's Avatar
    assigned static ip address
    Exactly what address and what's the gateway address of the router?

    changed captive portal server to localhost
    localhost is the phone itself.

    my theory is the phone is checking the quality of the internet connection and deeming it not fit and so disconnecting even though the option of smart network switch is disabled, i think this also because i cant connect to a wifi signal that has no internet connection for example
    That should make no difference, the phone is connecting to the router, not to the internet.

    i think for it to check the internet it must be sending a ping to an outside server and either it is unreachable or there is a timeout value that is too small and so if it takes too long it deems the connection unusable,
    Which still wouldn't make it disconnect from the router - they're on 2 different layers

    the internet at my home is significantly slower than outside hotspots as i live rural and have a broadband speed of max 4.5mbs
    That's normalk - for every packet you're sending, it has to be sent many times before it's finally received at the server. The same thing in reverse for packets coming from the server to your router.

    does anyone know of where the code is that would cause this sort of connection quality check and if its possible for me to disable or modify it manualy
    No, there's no "connection quality check" that would disconnect the phone from the router. If there was, you wouldn't be able to use any public wifi (since you can't get physically close enough to the router).

    Put the phone on the router, when it's connected, and see what happens. Unless the antenna in the phone is disconnected, that shouldn't make any difference.

    If it connects with a public wifi and stays connected, or if your girlfriend's phone stays connected to her router, I'd suspect it's a failing wifi radio in the phone. (And the only way any shop will check that is to replace parts - probably the motherboard.)
    11-09-2018 02:53 PM
  3. andromike's Avatar
    Hithanks for the reply

    My gateway address is 192.168.1.254, i asigned an address of 192.168.1.96,

    I didnt realise localhost was the phkme itself...anyway i had also tried asigning different servers, and also the address of the router

    I agree it shouldnt make any difference the quality of the internet connection, as i said the "smart network switch" is disabled, which apparently checks the internet qualityand swaps to mobile data if its deemed faster..but its disabled, the strange thing is when it connects to an ap, for a split seccond it says checking internet quality

    What i dont understand is whats causing it to leave the message by the ap name under wifi settings of "internet not available" it seems to be checking something for it to deem the wifi as having no access to the outside world

    When i mean connection quality check, i mean quality of the internet connection, not the wifi signal intensity


    Thanks
    11-09-2018 08:57 PM
  4. methodman89's Avatar
    ' and i am rooted.'
    And all bets are off.
    11-10-2018 09:13 AM
  5. andromike's Avatar
    As far as i remember..this problem was happening before the rooting process

    The thing is i should be able to connect to an ap that has no internet for example to access a repeater in order to set it up but i cant

    It definatley seems as though its checking for a reliable internet connection somehow..not happy with it and disconnecting

    I have used wifi analyzer to show me the signal strength of the router and repeater and it shows them fine..so i dont think its a radio or antenna issue bc its clearly recieving the signals in order to display them...also the fact it will stay connected to an outside hotspot rules this out too

    Puzzled
    11-10-2018 09:33 AM
  6. andromike's Avatar
    Update..

    Well now I'm running on lineago is 14.1 based on android 7.1

    WiFi seems a little more stable but still disconnects, I see the same baseband version is being used as was on the official m ROM

    I wonder if this is a router compatibility issue

    Has anyone had similar issues using a BT smart hub 6 ?
    Today 02:34 PM

Similar Threads

  1. Can't use Android Auto on my Samsung A5
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-09-2018, 08:56 PM
  2. Can I transfer my sim card from my Samsung J7 to my new iPhone 6s plus?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-09-2018, 08:25 PM
  3. Arrows next to wifi symbol
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-09-2018, 04:38 AM
  4. Can't use Android Auto on my Samsung A5
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 11-08-2018, 11:27 PM
LINK TO POST COPIED TO CLIPBOARD