1. owenrg's Avatar
    I don't know what to do at this point. I've toggled off block offensive words in every setting I can find. I cleared the cashe and storage on the Google app and Gboard app... Still turns f*** into that. Seems people I've been having issues with this for quite some time but it just started for me. Any suggestions?
    01-25-2019 11:39 AM
  2. B. Diddy's Avatar
    I moved this from the Android Apps forum to the General Help forum, since the former is intended for developers to promote their apps.

    Is this only on a particular website or in a particular app? Or does it happen even with private documents, like in Google Docs?
    01-25-2019 12:10 PM
  3. owenrg's Avatar
    Thanks for having this to the right place.

    Anytime I use Gboard voice to text. Squeezing the phone (pixel 3) and saying a curse word works fine. Using voice to text on the Google keyboard results in s***.

    I've cleared cache and data from the Google app and Gboard.. no dice. I've searched all over the place and have tried to find all the hidden places where the toggle for offensive words can be found. I'm out of ideas.
    01-25-2019 07:12 PM
  4. B. Diddy's Avatar
    Just to be sure -- you've gone to Settings>Language & Input>Virtual Keyboard>Google Voice Typing and turned off the Block Offensive Words toggle there, right?
    01-25-2019 08:40 PM
  5. owenrg's Avatar
    Yup. And under the Gboard settings too.
    01-25-2019 09:23 PM
  6. B. Diddy's Avatar
    Which phone do you have? Does it also happen in Safe Mode?
    01-25-2019 09:26 PM
  7. Alex Aronowitz's Avatar
    I don't know what to do at this point. I've toggled off block offensive words in every setting I can find. I cleared the cashe and storage on the Google app and Gboard app... Still turns f*** into that. Seems people I've been having issues with this for quite some time but it just started for me. Any suggestions?
    https://www.howtogeek.com/363659/how...your-messages/

    Took me far too long but I can swear again! you have to toggle off the one mentioned in the above article as WELL as the one everyone knows about.

    So one must toggle off "block offensive words" under "text correction" (see link above for how to find "text correction" AND

    One must toggle off "Hide offensive words" under - system > languages & input >Virtual keyboard > google voice typing

    If you have done both that and added the words you like to the personal dictionary... well then you might be F*****
    05-06-2019 08:27 PM
  8. B. Diddy's Avatar
    F*@% yeah!
    mustang7757 likes this.
    05-06-2019 10:45 PM
  9. winja's Avatar
    There are actually three different locations to turn hide offensive words off. In the system settings, in the Gboard settings and also in the voice to text settings... I have turned all of these f****** things off and for f***** sake it's still f****** sensors every f****** time I f****** cuss. It literally just started today 4/21/20. I have never had a f****** problem in the f****** past I have no f****** idea how to f****** fix this Google Pixel 2 is what I'm using. Do I need to maybe f****** change the f****** keyboard to something else?
    04-21-2020 05:44 AM
  10. Firefyter's Avatar
    Having the same problems with my Pixel 3XL using Gboard. I've checked and the blocking is turned off everywhere. Frustrating.
    04-21-2020 04:39 PM
  11. AC71984's Avatar
    Also having the same issue. Ever since the update. Block offensive is turned off in every imaginable location
    Pixel 4 here

    Edit: I went to the Gboard app, cleared cache and storage. Fired it up. And it seems to be okay now.

    Edit 2: so after downloading the keyboard for quicker voice recognition, it started doing it again.
    04-21-2020 05:53 PM
  12. coop2112's Avatar
    I dug and dug and found the setting on my LG G7. Go to: Settings, scroll down to Language & input, On-screen keyboard, Gboard, Text correction, Block offensive words. It works! I've spent a lot of time looking for this setting. What a pain. Jump through hoops. I swear that setting wasn't there before. Maybe came with an update. There is another setting that says the same thing but DOES NOT work. It's under Settings, Language & input, On-screen keyboard, Gboard, Voice typing, Offline speech recognition, Hide offensive words. Again, turning this off DID NOT fix it. Also I came across this same screen with this setting by digging through other Settings so beware. You have to find the first one I mentioned but it can't hurt to turn this one off too.
    04-21-2020 11:45 PM
  13. TNK Guns's Avatar
    It happened to me as well. I have a Pixel 4 and cleared everything, rolled back gBoard and all was perfect. The problem is that the voice to text was super slow and it was not picking up all the words. I updated it and nothing but ***** whenever I swear, and I swear a lot. Totally annoying and honestly, I am an adult and my phone should be the way I want it to be.
    04-22-2020 12:01 AM

Similar Threads

  1. Location services on or off .
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-25-2019, 12:58 PM
  2. How do I turn message blocking off
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-25-2019, 12:13 PM
  3. To restore beuty mode that disappeared on camera?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-25-2019, 12:11 PM
  4. s9 create contact from text
    By Bjr136 in forum Ask a Question
    Replies: 1
    Last Post: 01-25-2019, 10:50 AM
LINK TO POST COPIED TO CLIPBOARD