1. androiduser546's Avatar
    I am studying abroad this semester in Senegal, and was hoping to get a local SIM card to use in my phone here, as the service/data is much cheaper that way than purchasing an international plan. I purchased a SIM card from Orange and popped it in. Booted up my phone, and it loaded up to the lock screen like normal. However, after several seconds the screen went black and I once again saw the animated Samsung logo. It loaded up to the lock screen and then repeated the process. It keeps doing this over and over; I believe it to be a firmware issue. I have tried multiple avenues to remedy the problem: changing my network settings under "More Networks", deleting most apps that did not come with the phone, making sure there is no SIM card lock pin enabled, and simply reinserting the SIM card. Nothing seems to make any difference, and I am ready to try messing around with the firmware. Any other ideas or advice?

    Extra note: I have been told by my phone carrier in the US (Verizon) that my phone is indeed unlocked.
    01-31-2019 02:37 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Just to be clear, this is the Verizon-branded S5, right? Since Orange in Senegal doesn't have LTE, what if you go to Settings>Mobile Networks>Preferred Network Type and make sure only GSM is selected (as opposed to LTE)?
    01-31-2019 04:23 PM
  3. Rukbat's Avatar
    And not CDMA, which is what the Verizon version would probably have been set to. (Luckily, the Verizon S5 has GSM also - not all CDMA phones of that vintage did. Even the US Cellular version of the S5 didn't.)
    02-01-2019 04:09 PM
  4. androiduser546's Avatar
    Yes, it is the Verizon-branded S5. To respond to both your replies, I've tried the Orange SIM card with all the different settings under "Preferred Network Mode" and it hasn't made any difference. Fyi, the three options on my phone are "Global", "LTE/CDMA", and "LTE/GSM/UTMS". There is no option that is solely GMS. I don't know if this is important, but whenever I hold the power button, pull up the menu and choose "Power off", it does the normal powering-off animation, screen goes black (as it should), and then it proceeds to start to show the scrolling Samsung logo, like I didn't just tell it to turn off! It doesn't get all the way through the animation, just does part of the logo and then the screen goes black and it's off as it should be. Also I've tried putting my phone in airplane mode with the Orange SIM card in, and it does the same thing, restarting over and over until I turn it off. Makes me think it's not a network issue. Thoughts?
    02-16-2019 07:25 AM

Similar Threads

  1. Why do I suddenly have a second lock screen to swipe through?
    By tch1965 in forum Samsung Galaxy S9 & S9+
    Replies: 9
    Last Post: 07-09-2020, 01:18 PM
  2. New pie questions
    By kyleresq in forum Samsung Galaxy Note 9
    Replies: 8
    Last Post: 02-01-2019, 11:56 AM
  3. Replies: 8
    Last Post: 02-01-2019, 10:58 AM
  4. New AT&T Update - 1,831 MB in size
    By justafew in forum Samsung Galaxy Note 9
    Replies: 31
    Last Post: 01-31-2019, 10:03 PM
  5. Replies: 1
    Last Post: 01-31-2019, 01:57 PM
LINK TO POST COPIED TO CLIPBOARD