1. Trevor Olson's Avatar
    I just got myself a new to me Galaxy S8. Been really happy with it so far in general except that it seems that Google Duo isn't working. Hoping someone out there may have a fix for me.

    When I try to make a call with Duo, I am greeted with two different ring tones. It seems like there is one ring tone before the other person answers, and after they attempt to answer, the ring tone changes on my end. However I only ever see my video on my screen and it never connects.

    If I try to answer a call with Duo, the screen goes black, and I see a spinning circle with "Video Loading" on it. But video never pops up.

    I've tried rebooting my phone, reinstalling Duo, signing out of Duo and back in, logging off Wi-Fi and using only data, reconnecting and reconnecting to Wi-Fi.

    Duo works just fine on my laptop on the same network, and it worked fine on my old phone before I replaced it.

    Also, Snapchat video calling works just fine on this new phone. I much prefer Duo over snapchat though, and would love to get it up and running!

    Any ideas out there on what I can do to rectify this situation? Thanks all in advance!
    esevenb likes this.
    08-29-2019 08:20 PM
  2. esevenb's Avatar
    I just got myself a new to me Galaxy S8. Been really happy with it so far in general except that it seems that Google Duo isn't working. Hoping someone out there may have a fix for me.

    When I try to make a call with Duo, I am greeted with two different ring tones. It seems like there is one ring tone before the other person answers, and after they attempt to answer, the ring tone changes on my end. However I only ever see my video on my screen and it never connects.

    If I try to answer a call with Duo, the screen goes black, and I see a spinning circle with "Video Loading" on it. But video never pops up.

    I've tried rebooting my phone, reinstalling Duo, signing out of Duo and back in, logging off Wi-Fi and using only data, reconnecting and reconnecting to Wi-Fi.

    Duo works just fine on my laptop on the same network, and it worked fine on my old phone before I replaced it.

    Also, Snapchat video calling works just fine on this new phone. I much prefer Duo over snapchat though, and would love to get it up and running!

    Any ideas out there on what I can do to rectify this situation? Thanks all in advance!
    Like
    08-29-2019 08:22 PM
  3. B. Diddy's Avatar
    I moved this from the Android Apps forum to the General Help forum since the former is intended for developers to promote their apps.
    @esevenb, there's a Like button for posts -- click on the heart icon associated with the post, rather than typing out "Like."
    08-29-2019 10:51 PM

Similar Threads

  1. Banking apps still not working on Android 10
    By Kirstein Gourlay in forum Android 10
    Replies: 4
    Last Post: 09-03-2019, 09:11 PM
  2. not working USB tethering - Galaxy S10e to Xubuntu 18.04
    By foxreymann in forum Samsung Galaxy S10e
    Replies: 1
    Last Post: 08-30-2019, 02:18 PM
  3. Coolpad legacy will not save contacts
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 08-29-2019, 10:57 PM
  4. Replies: 3
    Last Post: 08-29-2019, 10:56 PM
  5. not working USB tethering - Galaxy S10e to Xubuntu 18.04
    By foxreymann in forum Ask a Question
    Replies: 0
    Last Post: 08-29-2019, 03:01 PM
LINK TO POST COPIED TO CLIPBOARD