1. Celena9x's Avatar
    I'm currently using a Blackberry DTEK60 and my friend is using a Galaxy S7 Edge. Both of our devices do not work on either of our home networks, and we are the only people using android in our families. Unfortunately all the apple devices work ( of course). WiFI shows connected with strong signal but nothing loads. I've forgotten and re added the networks multiple times, and I've rebooted routers and modems multiple times, no luck. It is very frustrating, considering I convinced my friend to switch to android. She is not very happy with me... What could possibly be wrong? I formally owned a BlackBerry PRIV as well, and I thought it was maybe just that device specifically, but nope. It seems any android device I have owned I've always had a terrible and frustrating experience with wifi anywhere I go. Could somebody please help! Both running Marshmallow.
    10-08-2019 10:43 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! I moved this from the General News forum to the General Help forum for more appropriate traffic.

    Do either of you have difficulty connecting to other wi-fi networks, like public ones at your local library or coffeeshop? Or does it only seem to be your home networks? What kind of security are your routers using -- WPA2-PSK/AES, or something older?
    10-09-2019 12:36 AM
  3. blak8830's Avatar
    I had similar issues on a different phone. Turns out I had to go to advanced settings during wifi network setup and select "hidden network", "yes" before the phone would connect. Are your networks hidden?
    10-09-2019 07:54 AM
  4. Rukbat's Avatar
    If not, check the router WiFi encryption. If it's TKIP ot TKIP+AES change it to AES.
    10-09-2019 02:25 PM
  5. SpookDroid's Avatar
    And I'd also try chaging the router's channel. The S7 especially was known for having a finicky WiFi chip that worked wonky with certain channels and certain router brands (TP Link and some Netgear ones from most reports).
    10-09-2019 05:34 PM
  6. Morty2264's Avatar
    Welcome to Android Central!

    I feel like this kind of thing happened to me over the years, as well. I don't think it's platform- or manufacturer-specific, though. I see you've tried rebooting the routers - that would have been one of my suggestions. Perhaps if all routes fail, call your network provider and see what they say.

    Keep us posted on your situation, OP!
    10-12-2019 09:53 AM

Similar Threads

  1. Switching from v20 to v40?
    By dlcpa in forum LG V40
    Replies: 16
    Last Post: Yesterday, 08:43 AM
  2. Switch to v40?
    By dlcpa in forum LG V20
    Replies: 10
    Last Post: 10-10-2019, 08:27 AM
  3. Replies: 2
    Last Post: 10-09-2019, 05:57 AM
  4. Please help me figure out the correct rapid-charge adapter/cable for my S10+
    By Android Central Question in forum Samsung Galaxy S10 & S10+
    Replies: 8
    Last Post: 10-09-2019, 05:11 AM
LINK TO POST COPIED TO CLIPBOARD