1. LimuHead's Avatar
    My Sandisk 64g micro-sd has a couple of corrupt files (torrent movies that didn't download correctly) and I've been trying to delete them but have had no luck.

    When I put the card in my PC it says that the card is locked and read only. Switching the lock on the adaptor does not work. (I just bought a new adaptor & it doesn't work either).

    At this point I can't even reformat the card because neither my GN3 nor my PC will allow me to do anything but add more data to the card.

    How do I erase these files?

    If I can't erase then how do I get the micro sd to reformat?

    Please help!

    All advice appreciated.

    Posted via Android Central App
    01-10-2014 04:14 PM
  2. LimuHead's Avatar
    Here's a little more weirdness I forgot to mention.

    My phone will allow me to delete corrupt and normal files, but only until the phone is rebooted - then the deleted files return....

    I can't figure it out...

    Help pleeeeeeaaassssseee!

    Posted via Android Central App
    01-10-2014 04:40 PM
  3. someguy01234's Avatar
    Try to do a diskscan first to see if it fix the file corruption issue.

    You need to format the microSD as FAT32 for the phone to recognize it, so you can't use Windows to do it, since it will auto format 64gb as exFAT.

    You can use RMPrepUSB to format: Latest RMPrepUSB versions + downloads - RMPrepUSB
    The interface looks daunting, but just select the MicroSD, select FAT32, and press the Prepare Drive button. Just be careful which drive you selected in the list to format.
    01-10-2014 04:42 PM
  4. LimuHead's Avatar
    Thanks. I've run diskscan and it said everything was okay. Go figure.

    The card was formatted by my phone when I first bought it.

    The problem is my PC and my phone refuse to reformat the card or allow me to delete (permanently) files.

    Thanks for the input.
    - Limu

    Sent from my SM-N900T using Tapatalk
    01-10-2014 04:48 PM
  5. LimuHead's Avatar
    Just tried the RMPrep program. It didn't work either but did give an information page that appeared for about 1.5 seconds. It was way to fast read.

    Thanks again!

    Posted via Android Central App
    01-10-2014 05:06 PM
  6. someguy01234's Avatar
    It looks like a failed card.
    LimuHead likes this.
    01-10-2014 09:20 PM
  7. brian7751's Avatar
    i had this problem in the past and i was able to fix it so dont give up hope on it too bad i cant remember what i did
    LimuHead likes this.
    01-10-2014 11:34 PM
  8. Dviper27's Avatar
    Sometimes you will have to reformat the drive. Sounds complicated but it really isn't.
    LimuHead likes this.
    01-11-2014 05:54 PM
  9. LimuHead's Avatar
    Sometimes you will have to reformat the drive. Sounds complicated but it really isn't.
    Thanks. Any idea how this is done?

    Posted via Android Central App
    01-11-2014 06:14 PM
  10. brian7751's Avatar
    hey i just had the write protected thing happen to me on a usb drive i used this program its a free trial but it worked for me open the program click continue for free click on microsd card click continue then click LOW Level Format
    dont check the box for quick formatting just click format it will say failed while its formatting but ignore it after formatting check the quick formatting box and format again just to be sure hopefully this helps it worked for me

    01-17-2014 03:19 AM
  11. j deal's Avatar
    It doesn't work...
    12-31-2014 12:45 PM
  12. risus's Avatar
    After setting the disk write flags and adding the WriteProtect registry entries with no luck, this worked for me. Thanks!
    03-22-2016 12:43 PM

Similar Threads

  1. HTC One - HELP! MALWARE going to droidresearchapp.info
    By Chris_Page in forum Android Security Talk
    Replies: 14
    Last Post: 02-20-2014, 01:24 AM
  2. HELP rooting my S4 and enable wifi
    By tlp560 in forum Sprint Samsung Galaxy S4
    Replies: 13
    Last Post: 01-13-2014, 09:16 PM
  3. moved most of my apps to sd card
    By sjsmith1708 in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 01-10-2014, 06:57 PM
  4. help factory reset
    By xnunziatax in forum AT&T Galaxy S III
    Replies: 2
    Last Post: 01-10-2014, 03:39 PM
  5. Bootloop htc one m7 international help!!!!!!!!!!!!!!!
    By Luckartdo225 in forum Legacy Android & Other OS's
    Replies: 0
    Last Post: 01-10-2014, 02:26 PM